Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 8342 - USER TEST: Compiler feedback needs to be more obvious
USER TEST: Compiler feedback needs to be more obvious
Status: VERIFIED INVALID
Product: ide
Classification: Unclassified
Component: UI
-FFJ-
All All
: P4 (vote)
: 6.x
Assigned To: Chris Ledantec
issues@www
:
: 17639 (view as bug list)
Depends on: 8997
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-10 02:29 UTC by jhoffman
Modified: 2005-07-13 23:31 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jhoffman 2000-11-10 02:29:33 UTC
Over half the participants in the FFJ user test did not realize that a compile
had completed.  They did not notice the light lavender message in the main
window's status bar.

Some expected a message to be posted in the Editor's status bar.  Several also
wanted a more explicit message (see bug 7727) of the format:
"Completed compile of file <fname> <successfully/with errors>"

Another user suggested putting the compilation status message in the output
window and displaying it whether or not there were errors.
Comment 1 Svata Dedic 2000-11-10 06:43:59 UTC
The NetBeans core (that manages the output window) or Java module (that manages
compilers) do not have control over the Editor window. Besides that, if user
selects nodes in the Explorer and says "compile", the message is irrelevant to
sources being edited in the SourceEditor. As for output window/status message,
that's another story.
Can we please discuss the exact messages/behaviour on nbusers/nbui ?
Comment 2 anovak 2001-01-12 13:32:59 UTC
A task for UI?
Comment 3 Jesse Glick 2001-01-17 14:32:59 UTC
Linking to a suggested implementation.
Comment 4 Chris Ledantec 2001-06-21 14:57:41 UTC
please follow the progress of the 'global status indicator' proposal and 
discussion on nbui.

http://ui.netbeans.org/docs/hi/global_status/globalstatususerview.html

cL
Comment 5 Chris Ledantec 2002-04-08 14:57:10 UTC
changing this to defect as it has been reported in bug 17639.

the status spec has been updated since it's original posting here as well.
Comment 6 Chris Ledantec 2002-04-08 14:57:44 UTC
*** Issue 17639 has been marked as a duplicate of this issue. ***
Comment 7 Chris Ledantec 2003-10-20 12:02:39 UTC
this seems to be dead and tied to status feedback improvements. closing.
Comment 8 Marian Mirilovic 2005-07-13 23:31:58 UTC
closed


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo