Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 83271 - [55cat] Screen not updating properly after window dnd operation
[55cat] Screen not updating properly after window dnd operation
Status: RESOLVED FIXED
Product: installer
Classification: Unclassified
Component: Code
5.x
Macintosh Mac OS X
: P2 (vote)
: 5.x
Assigned To: issues@installer
issues@installer
5.5_fix
:
: 83276 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-23 13:07 UTC by vernons
Modified: 2006-10-31 08:08 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Invalidated screen issue (overwrite) (136.35 KB, application/pdf)
2006-08-23 13:08 UTC, vernons
Details
Screen before attempting to move HTML palate (91.11 KB, image/png)
2006-09-20 10:46 UTC, vernons
Details
main screen after closing project (after moving HTML palate) (58.79 KB, image/png)
2006-09-20 10:48 UTC, vernons
Details
Screenshot after removing user dir (.netbeans) (84.16 KB, image/png)
2006-09-21 10:03 UTC, vernons
Details
About->Detail screenshot (96.88 KB, image/png)
2006-09-21 11:01 UTC, vernons
Details

Note You need to log in before you can comment on or make changes to this bug.
Description vernons 2006-08-23 13:07:46 UTC
[ JDK VERSION : 1.5.0_06 ]

After moving a palate from one location to another some areas of 
the screen appear to not be updated properly (overlaying of 
information).
Comment 1 vernons 2006-08-23 13:08:36 UTC
Created attachment 33193 [details]
Invalidated screen issue (overwrite)
Comment 2 Michael Frisino 2006-08-29 02:03:53 UTC
Moving the palette from what location to what location? Can you give more
descriptions? I do not see this on Windows. Do you have oportunity to see if it
is reproducible on windows or only on Mac?

Alexey A, can you go and check this on a Philip's MAC?
Comment 3 vernons 2006-08-30 08:59:50 UTC
My apologies for the delayed response. I tested on the PC and the issue is not reproducible on the PC. 

On the Mac, it seems moving about any palette while in the BPEL Design view results in refresh problems 
across the palettes (including other palettes) and the Design View as well. In this specific case I had made 
the Properties palette visible and moved it from the right hand area of the screen to the bottom area of the 
screen so it would appear as a tab alongside the Output palette.
Comment 4 vernons 2006-08-30 11:19:59 UTC
The palette related bugs seem to be global and not related to the Enterprise functionality. Sorry I didn't 
realize this before filing the report. Can you please help me reassign to the appropriate group or advise 
me how to do so?
Comment 5 Manish Malhotra 2006-09-08 19:07:36 UTC
*** Issue 83276 has been marked as a duplicate of this issue. ***
Comment 6 pcmreddy 2006-09-11 15:35:56 UTC
As per request from BPEL engineering I am moving this issue to Core/palette.
Comment 7 Marian Mirilovic 2006-09-20 09:04:32 UTC
We are in HR, so there is no plan to intagrate issues with the P3 and lowest
priority to NB 5.5 codeline. 
If you still want to fix this issue in NB 5.5 add "5.5_candidate" to status
whiteboard. 
Thanks in advance.
Comment 8 vernons 2006-09-20 09:28:17 UTC
Originally I thought this bug only effected the Enterprise Pack, so I thought it inconvenient but workable 
(restarting the IDE after repositioning a menu seems to make things more 'sane' again), however since it 
actually effects all graphic design palates, I have changed the priority and still hope it can be addressed as 
quickly as possible.
Comment 9 Stanislav Aubrecht 2006-09-20 09:49:44 UTC
i can't reproduce this issue.

can you pls try reproducing the repaint problem with e.g. html or form palette
window?
Comment 10 vernons 2006-09-20 10:46:21 UTC
Created attachment 34221 [details]
Screen before attempting to move HTML palate
Comment 11 vernons 2006-09-20 10:48:46 UTC
Created attachment 34222 [details]
main screen after closing project (after moving HTML palate)
Comment 12 vernons 2006-09-20 10:52:09 UTC
The bug is very easy to replicate. If you attempt to drag a palate to any other location, other views start to 
display strange artifacts. In the above two examples I simply dragged the HTML palate and it 'hiding' the 
HTML that was in the primary code window in the first sample (Picture 1.png -- Wed Sep 20), then when I 
closed the project the main window is depicted in the second image (Picture 6.png)
Comment 13 Stanislav Aubrecht 2006-09-21 09:22:52 UTC
and all this is reproducible with a clean user dir, right?
Comment 14 vernons 2006-09-21 10:03:44 UTC
Created attachment 34297 [details]
Screenshot after removing user dir (.netbeans)
Comment 15 vernons 2006-09-21 10:09:43 UTC
Yes. Even after removing the User Dir the same problem occurs. I've attached a new screenshot(Picture 
1.png Thu Sep 21). This after I drag and drop the Files tab from the top left tabpanel to the bottom left 
tabpanel.

Things work fine while any tab is in it's default position, but dragging/dropping any tab seem to cause 
invalidation (which continue until the application is restarted).
Comment 16 Stanislav Aubrecht 2006-09-21 10:20:22 UTC
so this bug is not palette related - reassigning to window system

i'm not able to reproduce the bug, is there anything special about your
environment setup?
can you try some other netbeans builds as well pls? (e.g. some 6.0 milestone build)
Comment 17 vernons 2006-09-21 11:01:36 UTC
Created attachment 34301 [details]
About->Detail screenshot
Comment 18 vernons 2006-09-21 11:17:26 UTC
My configuration is pretty standard, I think. PowerBook G4 1GHz/1GB running OS X 10.4.7 Java version 
1.5.0_06

I've just download and installed Netbeans 6-M3 and have played with the panels and they seem to work 
fine. 

Initially I thought this was might be related to the Enterprise Pack, but it seems to effect all palates. I'll 
download another copy of 5.5 beta and try it stand-alone, without the Enterprise Pack installed. I'll add 
another update when I've had a chance to do this.
Comment 19 vernons 2006-09-21 15:38:29 UTC
OK. I'm back to this being an Enterprise Edition issue. 

I installed a fresh version of 5.5Beta2 without the Enterprise pack I'm able to drag-and-drop tabs without 
any issues. After installing the Enterprise Pack dragging and dropping any palette results in refresh 
artifacts.
Comment 20 vernons 2006-09-21 15:42:38 UTC
OK. I'm back to this being an Enterprise Edition issue. 

I installed a fresh version of 5.5Beta2 without the Enterprise pack I'm able to drag-and-drop tabs without 
any issues. After installing the Enterprise Pack dragging and dropping any palette results in refresh 
artifacts.
Comment 21 Stanislav Aubrecht 2006-09-21 15:46:20 UTC
reassigning to j2ee module (i hope it's right one) as per the previous comment
Comment 22 Petr Jiricka 2006-09-21 18:13:51 UTC
J2EE is not correct, assigning to enterprise.
Comment 23 Michael Frisino 2006-09-21 21:13:45 UTC
alexey can you look at this on Phillip's MAC.
Comment 24 Michael Frisino 2006-09-25 16:21:07 UTC
Ok, here is findings.

Apple has specific option for Apple UI rendering. This is called Quartz system.
The default is that the Quartz system is on. 
In order to turn Quartz system on or off explicity you can use the option:
-J-Dapple.awt.graphics.UseQuartz=true | false

Like I said, by default the value is true.
For the default true, we have no problems.

But when the setting is changed ot "false" then we see quite a few rendering
problesm. And we do not think we can or have time to investigate and fix any of
these rendering problems. They may not be fixable. 

In previous release of EntPack the Quartz system was in effect and we did not
have problems.

But for some reason, the EntPack installer is now adding 
-J-Dapple.awt.graphics.UseQuartz=false

And with this setting the problems occur.

We do not know why installer has now decided to add this setting. 

Our recommendation is that this setting be removed.
Our other recommendation is that this be documented as a known problem for those
users who choose to usse the -J-Dapple.awt.graphics.UseQuartz=false option.


So we are reassigning to installer team :)
Comment 25 Kirill Sorokin 2006-09-25 16:34:54 UTC
Whoa, this one made a looong way :) UseQuartz=false was introduced wuiate long
ago to boost UML performance. It was tied to UML being installed, that;s why you
most probably did not see it. 

Now, as UML moves to you know where, we switched to always setting the property,
so in case the user adds UML, it does not perform like a pregnant turtle. I
doubt that it is in installer team competence to decide, please discuss w/
Sergey and let us know.
Comment 26 vernons 2006-09-26 08:55:44 UTC
I can confirm that setting -J-Dapple.awt.graphics.UseQuartz=true (in the {$InstallDir}NetBeans.app/
Contents/Resources/NetBeans/etc/netbeans.conf file) resolves the palette drag-and-drop issue. 

My $.02 on the issue would be use UseQuartz=true as the default. I'd rather things be slow than broken. If 
someone needs the speed then they could change the default.
Comment 27 Kirill Sorokin 2006-09-27 11:56:30 UTC
The useQuartz=false has been removed from installer. Thus things should be fixed
now.
Comment 28 _ rkubacki 2006-10-31 08:08:35 UTC
I just closed issue #88271 asking to turn off Quartz renderer by default.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo