Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 8290 - context help for property attributes
context help for property attributes
Status: CLOSED FIXED
Product: platform
Classification: Unclassified
Component: -- Other --
3.x
All All
: P3 (vote)
: TBD
Assigned To: Jesse Glick
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-08 17:51 UTC by Jan Benway
Modified: 2008-12-22 19:42 UTC (History)
4 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Benway 2000-11-08 17:51:29 UTC
We need to have some way to provide context-sensitive help for property
attributes. For example, clicking F1 while editing a property could bring up
specific help for that property. Also, Help buttons could be added to property
editor windows.
Comment 1 Peter Zavadsky 2000-11-09 12:14:59 UTC
Hi Jeffrey,

I think you mean you would like to have context help for properties, presented
in property sheets? If yes, the bug should be moved to core (propbably).
Properties module deals with .properties files (Resource Bundles) and context
help for key-value pair doesn't have a sense.

Please let me know, if I'm right. Then I'll move the bug to right module.

Peter
Comment 2 Peter Zavadsky 2000-11-10 14:15:59 UTC
Moved to core module.
Comment 3 Jesse Glick 2000-11-10 14:50:59 UTC
I think you mean openide, since it deals with where HelpCtx is available.

Note that for property editor windows, you can already have a Help button; just
use HelpCtx.setHelpIDString to assign a JavaHelp ID to the main panel of the
property editor. A Help button will appear automatically.

If you want F1 to work on a specific property in the Property Sheet (without a
dialog having been opened): (1) if it is OK you can already put help on the
associated Node as a whole which will apply to all properties for that node; (2)
if the extra specificity is really needed, I am pretty sure there is already an
enhancement request that Node.Property be permitted to have a HelpCtx, so please
look up this bug # in Bugzilla and mark this item a duplicate of it.
Comment 4 Jesse Glick 2000-12-05 18:24:59 UTC
Still awaiting comments/clarifications.
Comment 5 Paul Fussell 2001-01-27 03:40:59 UTC
I could not find another enhancement request in Bugzilla that Node.Property be
permitted to have a HelpCtx, so I'm adding my comments to this one. We do need
field-level help for each property in a property sheet. There are several
reasons:

1. Tooltips do not have adequate room to explain what to enter for many
properties.
2. We can do a help topic for each property sheet that shows all properties,
but the contents of property sheets are dynamic. For example, if several nodes
are selected in the Explorer, only those properties common to all selected
nodes are displayed.
3. Third-party application and web server plugins will provide properties to be
dynamically displayed in property sheets. It will be impossible for Sun to
anticipate what these properties are, so we cannot write help for them in a
Property Sheet topic. These properties will be documented by the server vendor.
The vendor will need to be able to supply a field-level JavaHelp map ID for
each property so the user can figure out what it is.
Comment 6 Jesse Glick 2001-01-27 15:35:59 UTC
OK.
Comment 7 Jesse Glick 2001-01-31 10:22:59 UTC
Fixed in the trunk. If you have a Node.Property object, you may set its "helpID"
ad-hoc property to be a (String) help ID. The Property Sheet will display this
help when the mouse is over that row. If you have a Node.PropertySet object, you
may again use "helpID"; the P.S. will display this help when the mouse is over
the tabbed area showing properties, and that tab is visible. Help continues to
default to the help for the nodes themselves.
Comment 8 Quality Engineering 2003-07-01 15:54:52 UTC
Resolved for 3.4.x or earlier, no new info since then -> verified
Comment 9 Quality Engineering 2003-07-01 16:13:40 UTC
Resolved for 3.4.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo