Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 82727 - Diagram synchronization doesn't work for removed but left ON diagram class element
Diagram synchronization doesn't work for removed but left ON diagram class el...
Status: VERIFIED FIXED
Product: uml
Classification: Unclassified
Component: General
5.x
All All
: P2 (vote)
: 6.x
Assigned To: Yang Su
issues@uml
GRIFFIN_CANDIDATE
:
Depends on:
Blocks: 80569 82730 87841 95818
  Show dependency treegraph
 
Reported: 2006-08-15 12:35 UTC by Andrew Korostelev
Modified: 2007-09-14 00:02 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Korostelev 2006-08-15 12:35:38 UTC
Diagram synchronization toolbar button doesn't remove from diagram
nested class element remaining there after it was removed from model and source.

how to reproduce:
- Create a java project
- Create a uml project and associate it to the java project
- Create a class diagram
- Add 'MyClass' class to the diagram
- Add 'Inner' class to the diagram
- Draw 'Nested Link' from 'Inner' class to 'MyClass'  
- Go to source of 'MyClass' class
- Remove 'Inner' class from 'MyClass' class
- Go to the diagram
  'Inner' class was not removed from the diagram.
press 'Diagram synchronization' button - class symbol is still on diagram.

Bug status is P2 because feature doesn't work for one of not rare situation...
Element will be removed after diagram reopening, but it is not a workaround for
feature which is designed to refresh diagram withous restarting...
Comment 1 Andrew Korostelev 2006-08-15 13:15:33 UTC
This bug is caused by issue 80569
Comment 2 Yang Su 2006-12-05 00:58:06 UTC
Since we disabled real-time synchronization, the repro step should be slightly
updated, basically add extra step to RE modified java project into existing uml
project, but the bug is nevertheless valid and should be addressed.
Comment 3 Peter Lam 2007-03-20 20:16:46 UTC
low use case not currently impacting our installed user base.
Comment 4 Yang Su 2007-07-17 23:31:43 UTC
added logic to validate element the node represents against model repository 
Comment 5 Peter Lam 2007-09-14 00:02:23 UTC
verified in build 20070913.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo