Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 8223 - Cannot access CVS settings from the project tab
Cannot access CVS settings from the project tab
Status: CLOSED FIXED
Product: platform
Classification: Unclassified
Component: Window System
3.x
PC Windows 3.1/NT
: P4 (vote)
: 3.x
Assigned To: akemr
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-07 00:27 UTC by jhoffman
Modified: 2008-12-22 19:36 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jhoffman 2000-11-07 00:27:11 UTC
Mount a CVS filesystem using the filesystem tab.
Right clicking on the mounted CVS directory adds both CVS and CVS Settings menu
items.
Add the filesystem to the project by selecting the Tools -> Add to Project menu
item.
Flip to the project tab and right click on the Root item.  The CVS menu items
do not appear.
Comment 1 jhoffman 2000-11-07 00:32:59 UTC
If you add a package within a mounted CVS filesystem to the project, the CVS
menu item does not appear when you right click on the package node on the
Project tab.
Comment 2 jhoffman 2000-11-07 00:34:59 UTC
If you add a package within a mounted CVS filesystem to the project, the CVS
menu item does not appear when you right click on the package node on the
Project tab.

Similarly, if you add a java file within a mounted CVS filesystem to the
project, the CVS menu item does not appear when you right click on the java
file node within the Project tab.
Comment 3 Martin Ryzl 2000-11-07 09:40:59 UTC
The problem is caused by DataShadow. Try to create a link - copy, paste as link
- and the link node has no FileSystem action.
BTW, it is hard to say which filesystem action set should be used - filesystem
of original object or filesystem of the link?
Comment 4 Martin Ryzl 2000-11-07 09:41:59 UTC
The problem is caused by DataShadow. Try to create a link - copy, paste as link
- and the link node has no FileSystem action.
BTW, it is hard to say which filesystem action set should be used - filesystem
of original object or filesystem of the link?
Comment 5 Martin Entlicher 2000-11-21 09:30:59 UTC
*** Bug 8487 has been marked as a duplicate of this bug. ***
Comment 6 Jan Zajicek 2001-01-23 09:30:59 UTC
Automated change of version from Other to Dev.
Comment 7 Jan Chalupa 2001-03-12 09:33:47 UTC
Version: 'Dev' -> 3.2
Comment 8 Robert Dankanin 2001-04-02 11:33:49 UTC
reassigned to Ales (suggested by Yarda)
Comment 9 akemr 2001-04-03 09:12:26 UTC
Fixed. Fix will be in dev build #160 and release32 build #20

FileSystemAction changed to allow DataShadow use FileSystem action of original 
DataObject.

See bug #5566 too.
Comment 10 Jan Zajicek 2001-05-03 10:59:17 UTC
verified in 3.2 release
Comment 11 Jan Chalupa 2001-05-05 20:51:41 UTC
Target milestone 3.2
Comment 12 Quality Engineering 2003-07-01 16:47:49 UTC
Resolved for 3.4.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo