Bug 81926 - Support for debugger window groups
Support for debugger window groups
Status: CLOSED FIXED
Product: debugger
Classification: Unclassified
Component: Code
5.x
All All
: P2 with 1 vote (vote)
: 6.x
Assigned To: Martin Entlicher
issues@debugger
: PLAN
: 122740 (view as bug list)
Depends on:
Blocks: 126927
  Show dependency treegraph
 
Reported: 2006-08-04 11:38 UTC by Alexander Zgursky
Modified: 2010-04-29 09:29 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Zgursky 2006-08-04 11:38:38 UTC
I'm not sure how this is to be implemented, but here is the problem:
we are working on the BPEL Debugger, which is the part of the Enterprise Pack.
In the BPEL Debugger most of the standard debugger windows are reused, some are
not used, and there are some additional BPEL-Debugger-spesific views.
Whenever user starts a debug session the same set of debugger views is opened
with no regard to what Debugger is used (Java, BPEL, ANT...). If user opens or
closes some views during a debug session - view states will be persisted so the
next time debugger is started the same set of views is opened. But, again, view
states are persisted with no regard to what Debugger is used.
I believe it would add much of a usability if some generic mechanism for
"debugger window groups" will be implemented.
Comment 1 Martin Entlicher 2008-05-13 21:32:32 UTC
*** Issue 122740 has been marked as a duplicate of this issue. ***
Comment 2 Martin Entlicher 2008-06-06 18:34:19 UTC
Implemented in trunk:
http://hg.netbeans.org/main/rev/a1985e2c2f9c

Java debugger implements this new approach, DebuggerEngineProvider.getServices() can return instances of
BeanContextChildComponentProxy, which are then examined for the component to open.
Comment 3 Quality Engineering 2008-06-07 16:09:12 UTC
Integrated into 'main-golden', available in NB_Trunk_Production #243 build
Changeset: http://hg.netbeans.org/main/rev/a1985e2c2f9c
User: mentlicher@netbeans.org
Log: #81926 - Support for engine-specific components to open/close when debugging starts/finishes.
Comment 4 Quality Engineering 2010-04-29 09:29:49 UTC
Verified ... and Closing all issues resolved into NetBeans 6.7 and earlier.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo