Bug 8178 - Can't compile any JSP with fastjavac
Can't compile any JSP with fastjavac
Status: CLOSED FIXED
Product: javaee
Classification: Unclassified
Component: Code
3.x
Sun Solaris
: P1 (vote)
: TBD
Assigned To: issues@javaee
issues@javaee
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-04 04:01 UTC by Ana.von Klopp
Modified: 2003-07-02 08:27 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ana.von Klopp 2000-11-04 04:01:05 UTC
Build 1137/using code on November 3

Compile any JSP. Regardless of encoding set in the JSP (or if none
is set) fastjavac (the default compiler) fails with

fastjavac: The "-encoding UTF8" option is currently limited to the current
system default encoding of "8859_1".
fastjavac: warning: The translation from encoding UTF-8 to UTF-8 is not
available on this system.
fastjavac: warning: All files will be processed as if in the "C" locale.
2 warnings
1 error

You can reproduce this by doing "New" -> JSP (HTML) and doing nothing
with the created JSP.
Comment 1 Petr Jiricka 2000-11-06 09:32:59 UTC
[1140] Fixed.
Comment 2 Marek Fukala 2001-06-12 08:48:35 UTC
[010611_2]
Comment 3 Quality Engineering 2003-07-02 08:27:43 UTC
Resolved for 3.4.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo