Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 81655 - Umbrella issue to track XMLtools/NB issues.
Umbrella issue to track XMLtools/NB issues.
Status: VERIFIED FIXED
Product: soa
Classification: Unclassified
Component: -- Other --
5.x
All All
: P1 (vote)
: 5.x
Assigned To: issues@soa
issues@soa
55EP_BETA_WAIVED
: UMBRELLA
Depends on: 68765 74978 74984 77333 79365 80123 80128 81115 83740 83963 84047 85031
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-02 05:47 UTC by pcmreddy
Modified: 2007-08-15 20:03 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pcmreddy 2006-08-02 05:47:04 UTC
This is an Umbrella issue to track XMLtools/MN issues.
Comment 1 pcmreddy 2006-08-09 15:26:32 UTC
*** Issue 81028 has been marked as a duplicate of this issue. ***
Comment 2 pcmreddy 2006-08-09 15:28:18 UTC
Info from Issue 80128. Which is closed as duplicate of this issue.
The Schema view of the XSD editor leaves the document in a modified state when
undoing changes back to the last save point. Ideally when the document is
reverted to a save point, it should be marked as unmodified. Due to issue 81023,
we cannot address this problem (initially reported in issue 77333).

To reproduce, open or create a schema document, in the Schema view make a change
(add or delete something), then undo -- the document is left dirty (it has '*'
in title) and Save is still enabled.

This used to work as expected, but issue 77333 was the result and to avoid that
more serious problem, we took the approach of leaving the document modified. In
either case, if issue 81023 were fixed, we could make our editor behave as
expected. See the code in SchemaColumnViewMultiViewElement (search for 81023).
Comment 3 Nathan Fiedler 2006-08-24 18:20:25 UTC
Adding issue 81115 which blocks fixing issue 77931.
Comment 4 Nathan Fiedler 2006-08-30 07:34:41 UTC
Issue 83740 blocks issue 83624.
Comment 5 Nathan Fiedler 2006-09-12 00:47:14 UTC
Issue 74984 blocks issue 77931.
Comment 6 pcmreddy 2006-09-21 05:21:37 UTC
All dependent issues are reolved for now. If needed we can reopen this again.
Comment 7 Nathan Fiedler 2006-09-21 23:38:41 UTC
Issue 68765 causes the find action in the XML schema editor to become disabled
after switching to and from the Design view (see issue 81374).
Comment 8 Michael Frisino 2006-09-25 16:28:14 UTC
still blocked by bug 68765.
Comment 9 pcmreddy 2006-09-27 16:44:11 UTC
All dependent issues are resolved as on 9/27/06
Comment 10 _ hong_lin 2007-08-15 20:03:44 UTC
Close "FIXED" issue against previous releases


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo