Bug 81127 - diagrams printed on landscape mode lost element labels and include garbage chars
diagrams printed on landscape mode lost element labels and include garbage chars
Status: VERIFIED FIXED
Product: uml
Classification: Unclassified
Component: Output
5.x
All All
: P2 (vote)
: 6.x
Assigned To: George Vasick
issues@uml
55uml_beta_rn, EXT-USER
:
: 97154 124401 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-26 04:11 UTC by Peter Lam
Modified: 2008-02-07 00:22 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Lam 2006-07-26 04:11:28 UTC
Regression from TPR3 release

repro steps:
- create a uml project of any type
- create a class diagram or any other diagram type
- create and name some elements on the diagram
- click on the Print Preview button from the diagram window toolbar
- click on Print Setup button from Print Preview dialog
- from the Print Setup dialog, click on Page Setup button
- from the Page Setup button, toggle the "Landscape" orientation radio button
and click on OK
- click on OK from the Print Setup dialog
Result: the preview on the Print Preview dialog should now display the diagram
in landscape format
- click on the Print button from the Print Preview dialog
- select a printer and click the OK button to send the diagram to the selected
printer
Result: the diagram printed to the paper on landscape mode has no element names
on any element. And the element component name are shifted down below each
element for classe and interface elements.
Comment 1 George Vasick 2006-07-27 23:33:50 UTC
I followed the steps provided in the description.  The printing wsorks fine for
me.  Note: I tested on Windows XP.
Comment 2 Peter Lam 2006-07-31 21:04:16 UTC
Looks like this is jdk 1.6 issue. I just verified with jdk 1.5 and it's ok too.
Since QE is now testing with jdk 1.6 as a primary jdk version, jdk 1.5 is a
secondary version now. 
Comment 3 Peter Lam 2006-08-04 00:08:01 UTC
This problem does not exist on Mac OS X system using jdk 1.6 (build 85 as the
latest that could be downloaded). On all other platforms, jdk 1.6 beta2 is build
86 which has this problem.
Comment 4 Peter Lam 2006-08-15 00:02:24 UTC
removed REGRESSION keyword since this is not a regression. It exists because JDK
1.6 is used.
Comment 5 Kris Richards 2006-09-21 19:51:59 UTC
has work around. Use java 1.5
Comment 6 Peter Lam 2007-03-03 08:17:08 UTC
*** Issue 97154 has been marked as a duplicate of this issue. ***
Comment 7 Joseph Silber 2007-09-10 13:18:16 UTC
release note added beta 1
Comment 8 Peter Lam 2007-09-11 06:42:58 UTC
This issue has been fixed in jdk 1.6.0_02 & _03 on Windows. Will verify in other platforms.
Comment 9 George Vasick 2007-09-21 19:40:47 UTC
Fixed in jdh 1.6_02 or later.  Please verify.
Comment 10 Peter Lam 2007-09-25 21:59:51 UTC
verified on solaris and linux platforms on both jdk1.6.0_02 and jdk1.6.0_03 that this issue has been fixed in
jdk1.6.0_02 and later.
Comment 11 Viktor Lapitski 2008-02-07 00:22:06 UTC
*** Issue 124401 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo