Bug 80919 - "CTL_MainWindow_Title_No_Project" resource from core cannot be used anymore
"CTL_MainWindow_Title_No_Project" resource from core cannot be used anymore
Status: RESOLVED FIXED
Product: apisupport
Classification: Unclassified
Component: Project
6.x
All All
: P2 (vote)
: 6.x
Assigned To: _ rkubacki
issues@apisupport
: REGRESSION
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-24 09:07 UTC by Martin Krauskopf
Modified: 2006-11-03 19:38 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
assertion due to missing CTL_MainWindow_Title_No_Project (3.77 KB, text/plain)
2006-07-24 09:08 UTC, Martin Krauskopf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Krauskopf 2006-07-24 09:07:35 UTC
e.g.

1) Create suite1 and suite2
2) Create a module in a suite1
3) Add the module (created in step 2) to suite2

Attached exception is thrown.

Cf. http://www.netbeans.org/nonav/issues/show_bug.cgi?id=79209 (CCing Radim)
Comment 1 Martin Krauskopf 2006-07-24 09:08:23 UTC
Created attachment 32122 [details]
assertion due to missing CTL_MainWindow_Title_No_Project
Comment 2 _ rkubacki 2006-07-24 12:54:54 UTC
$ nbcvs -q ci -m "#80919: moving main window title keys changed as part of
#79209 fix back because API support relies on them" core/windows
projects/projectui ide/branding
Checking in core/windows/src/org/netbeans/core/windows/view/ui/Bundle.properties;
/shared/data/ccvs/repository/core/windows/src/org/netbeans/core/windows/view/ui/Bundle.properties,v
 <--  Bundle.properties
new revision: 1.16; previous revision: 1.15
done
RCS file:
/shared/data/ccvs/repository/core/windows/test/unit/src/org/netbeans/core/windows/view/ui/MainWindowTest.java,v
done
Checking in
core/windows/test/unit/src/org/netbeans/core/windows/view/ui/MainWindowTest.java;
/shared/data/ccvs/repository/core/windows/test/unit/src/org/netbeans/core/windows/view/ui/MainWindowTest.java,v
 <--  MainWindowTest.java
initial revision: 1.1
done
Checking in
projects/projectui/src/org/netbeans/modules/project/ui/Bundle.properties;
/shared/data/ccvs/repository/projects/projectui/src/org/netbeans/modules/project/ui/Bundle.properties,v
 <--  Bundle.propertiesnew revision: 1.78; previous revision: 1.77
done
Checking in projects/projectui/src/org/netbeans/modules/project/ui/Hacks.java;
/shared/data/ccvs/repository/projects/projectui/src/org/netbeans/modules/project/ui/Hacks.java,v
 <--  Hacks.java
new revision: 1.23; previous revision: 1.22
done
Checking in
ide/branding/core/windows/src/org/netbeans/core/windows/view/ui/Bundle_nb.properties;
/shared/data/ccvs/repository/ide/branding/core/windows/src/org/netbeans/core/windows/view/ui/Bundle_nb.properties,v
 <--  Bundle_nb.properties
new revision: 1.7; previous revision: 1.6
done
Comment 3 _ rkubacki 2006-07-24 16:13:04 UTC
This should be OK now. I added test into core/windows with comment that these
keys are used in API support
Comment 4 Jesse Glick 2006-07-27 10:45:50 UTC
IMHO the original change was correct and apisupport just needed to be updated to
use the new bundle keys. No?
Comment 5 _ rkubacki 2006-07-27 11:49:54 UTC
In fact keys in core/windows are API now so it seems to be easier to access them
from projects/projectui if neceseary. At least we do not have to pay attention
what version of platform we are developing against and introduce some logic of
this kind into API support.

Probably we should document these keys into arch of core/windows (has to be
created) or openide/windows.
Comment 6 Jesse Glick 2006-07-27 20:30:10 UTC
The trouble with the original keys is that they are inappropriate for platform
developers. You want just one thing to brand; the "project" makes no sense. That
is why I welcomed the simplification. Of course some kind of switch in
apisupport would be necessary to support both old and new styles.

Oh well, probably not worth bothering with further.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo