Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 80569 - Inner class remains on class diagram after removing it from the source code
Inner class remains on class diagram after removing it from the source code
Status: VERIFIED FIXED
Product: uml
Classification: Unclassified
Component: Synchronization
5.x
All All
: P2 (vote)
: 6.x
Assigned To: Yang Su
issues@uml
COKE_REVIEWED
:
: 78708 87841 (view as bug list)
Depends on: 82727
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-19 12:59 UTC by bugbridge
Modified: 2007-09-13 18:09 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bugbridge 2006-07-19 12:59:46 UTC
Original submitter: sunflower

Description:

Steps to reproduce:

- Create a java project
- Create a uml project and associate it to the java project
- Create a class diagram
- Add 'MyClass' class to the diagram
- Add 'Inner' class to the diagram
- Draw 'Nested Link' from 'Inner' class to 'MyClass'  
- Go to source of 'MyClass' class
- Remove 'Inner' class from 'MyClass' class
- Go to the diagram
  'Inner' class was not removed from the diagram.
Comment 1 Craig Conover 2006-08-14 18:32:28 UTC
There is some sort of diagram redisplay issue.

Workaround: Close the diagram, reopen. The inner class element is no longer on
the diagram.
Comment 2 Andrew Korostelev 2006-08-15 12:25:28 UTC
*** Issue 78708 has been marked as a duplicate of this issue. ***
Comment 3 Andrew Korostelev 2006-08-15 12:28:59 UTC
Agree to change priotity from p2 to p3 because nested class leaved on diagram
can't break user's UML or java project.
But will file new issues caused by this one.
Comment 4 Andrew Korostelev 2006-08-15 13:14:27 UTC
see also bugs:
82727 Diagram synchronization doesn't work for removed but leaved on diagram
class element
82730 operations with class removed but leaved on diagram result in NPE
Comment 5 Yang Su 2007-07-17 23:38:47 UTC
*** Issue 87841 has been marked as a duplicate of this issue. ***
Comment 6 Yang Su 2007-07-17 23:40:19 UTC
fixed with issue 82727
Comment 7 Yang Su 2007-07-17 23:52:47 UTC
assign to myself
Comment 8 Yang Su 2007-07-17 23:54:01 UTC
fixed
Comment 9 Joanne Lau 2007-09-13 18:09:21 UTC
Fix verified in trunk 200709121200


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo