Bug 79580 - Jackpot failed to process any rule on projects from ide cluster
Jackpot failed to process any rule on projects from ide cluster
Status: RESOLVED FIXED
Product: contrib
Classification: Unclassified
Component: Jackpot
5.x
All All
: P1 (vote)
: TBD
Assigned To: issues@contrib
issues@contrib
:
Depends on:
Blocks: 78882
  Show dependency treegraph
 
Reported: 2006-07-03 12:28 UTC by Jan Becicka
Modified: 2006-08-30 01:11 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
messages.log (15.03 KB, text/plain)
2006-07-03 12:30 UTC, Jan Becicka
Details
Query and Refactor Log output (16.07 KB, text/plain)
2006-07-03 13:28 UTC, Jan Becicka
Details
Different exception (14.54 KB, text/plain)
2006-07-04 12:24 UTC, Jan Becicka
Details
And new log (25.49 KB, text/plain)
2006-07-04 12:24 UTC, Jan Becicka
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Becicka 2006-07-03 12:28:08 UTC
Todays NetBeans build, with fresh jackpot module from AU. JDK 1.6.0-beta2-b86,
Widnows XP, -Xmx1024m

I tried to remove ErrorManager from all modules within ide cluster. I opened all
these modules and tried to run Jarda's rules (apisupport/jackpotrules).
Unfortunately Jackpot failed with attached message. The problem is probably not
in Jarda's rules, because I cannot run any rule on these projects.
Comment 1 Jan Becicka 2006-07-03 12:30:11 UTC
Created attachment 31577 [details]
messages.log
Comment 2 Jan Becicka 2006-07-03 13:28:32 UTC
Created attachment 31584 [details]
Query and Refactor Log output
Comment 3 _ tball 2006-07-03 15:29:18 UTC
This issue appears to be due to compilation errors in some of the ide module's
test files.  The test source
editor\test\qa-functional\src\org\netbeans\test\editor\suites\abbrevs\data\testfiles\JavaAbbreviationsTest\Test.java
should be renamed to have a different suffix, since it not valid Java source. 
I'm not blaming those source files, of course, but they cause Jackpot errors to
surface.  

A bigger issue the Retouche team needs to decide is how Jackpot should handle
projects which contain Java sources which don't compile.  Currently Jackpot
allows errors which works for queries, but transformations on ASTs with errors
are likely to be incorrect.  It would be easy to block transformation if any
errors are found, but that can prevent use with projects that have test files
which intentionally have errors.  Some sort of file selection should be
possible, so that these error-containing files can be excluded from a Jackpot query.
Comment 4 Jan Becicka 2006-07-04 08:53:40 UTC
I renamed extension of
editor\test\qa-functional\src\org\netbeans\test\editor\suites\abbrevs\data\testfiles\JavaAbbreviationsTest\Test.java
and now I'm getting different exception.
Comment 5 Jan Becicka 2006-07-04 12:24:23 UTC
Created attachment 31622 [details]
Different exception
Comment 6 Jan Becicka 2006-07-04 12:24:54 UTC
Created attachment 31623 [details]
And new log
Comment 7 _ tball 2006-08-30 01:11:43 UTC
Fixed the exceptions from both logs, both due to poor ErroneousTree support.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo