Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 79530 - mapper isn't refreshed after adding a new element in .xsd file
mapper isn't refreshed after adding a new element in .xsd file
Status: VERIFIED FIXED
Product: soa
Classification: Unclassified
Component: BPEL Mapper
5.x
All All
: P2 (vote)
: 5.x
Assigned To: Ed Wong
issues@soa
ENTPACK_55_BETA_RN 55EP_BETA_WAIVED
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-30 22:06 UTC by _ hong_lin
Modified: 2006-09-25 09:34 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
mapper not refreshed snapshot (77.28 KB, image/png)
2006-06-30 22:06 UTC, _ hong_lin
Details
mapper refreshed after re-open IDE (82.00 KB, image/png)
2006-06-30 22:07 UTC, _ hong_lin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description _ hong_lin 2006-06-30 22:06:04 UTC
Build: NB 5.5 Dev (build 20060629200, Pack 2006.06.29)

To reproduce it:

1. Create a SynchronousSample sample project.
2. Open SynchronousSample.bpel and SynchronousSample.xsd in Editor Window.
3. Click the SynchronousSample.xsd in the Editor Widnow. In Schema view, click
the "Elements" item, then the "typeA" item in the right next column, then
"complexType", then "sequence". 
4. Right-click "sequence", select Add -> Element. Save the change.
5. Rename the new element to "paramB".
6. Click the SynchronousSample.bpel tab in the Editor Window. In the Design
view, click "assign" activity in the bpel diagram.
7. Open mapper window. Expand "inputVar -> inputType" and "outputVar ->
outputType" on both left side and right side.
==> new element "paramB" is not added under the inputType on both sides.
8. Close the mapper window and re-open it.
==> Get the same result as step 7.
(See the attached snapshot mapperNotRefreshed.png)

Workaround: Close the IDE and re-start it. (See the attached snapshot
mapperRefreshed.png)
Comment 1 _ hong_lin 2006-06-30 22:06:49 UTC
Created attachment 31562 [details]
mapper not refreshed snapshot
Comment 2 _ hong_lin 2006-06-30 22:07:18 UTC
Created attachment 31563 [details]
mapper refreshed after re-open IDE
Comment 3 Joshua Sandusky 2006-07-15 00:09:04 UTC
the mapper shows the change only when you switch out of the activity and then
back into it, which of course is not ideal. the mapper should automatically
update if at all possible without having to do this.
Comment 4 Ed Wong 2006-07-26 01:33:26 UTC
Assign to myself
Comment 5 Ritesh Adval 2006-09-22 01:01:35 UTC
This works for me. This used to be a problem pre windows group for mapper.
Marking as fixed.
Comment 6 skrishnan 2006-09-25 09:34:09 UTC
verified in build 060922.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo