Bug 7953 - Mysterious bug during CVS commit to web pages
Mysterious bug during CVS commit to web pages
Status: RESOLVED INVALID
Product: obsolete
Classification: Unclassified
Component: collabnet
3.x
PC Linux
: P1 (vote)
: TBD
Assigned To: support
issues@www
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-19 13:01 UTC by Jesse Glick
Modified: 2009-11-08 02:26 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Shell session using CVS incl. abort message (12.91 KB, text/plain)
2000-10-19 13:03 UTC, Jesse Glick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2000-10-19 13:01:14 UTC
I was cd'd to a checkout of nbbuild module and tried to commit a number of
changes to files in www/ (pages for nbbuild.netbeans.org). There was a CVS error
message (will make an attachment with shell session). The commit seemed to have
worked CVS-wise but the web pages do not seem to have been updated. Now
subsequent commits (to the same directory at least) continue to give the same
error (though they do not involve the erroneous file!) and nbbuild.netbeans.org
pages are not getting updated.
Comment 1 Jesse Glick 2000-10-19 13:03:59 UTC
Created attachment 201 [details]
Shell session using CVS incl. abort message
Comment 2 Jesse Glick 2000-10-19 14:57:59 UTC
Confirmed that *all* commits to nbbuild/www/ give the same error and fail to
update live site. When you fix this, please also ensure that
nbbuild.netbeans.org is updated to match the contents of CVS.
Comment 3 Jesse Glick 2000-10-20 17:14:59 UTC
Jack seems to be having similar problems updating look/ area.
Comment 4 Jesse Glick 2000-10-20 17:20:59 UTC
Well, the pages have now been updated on the actual website, and committing new
HTML does update nbbuild.netbeans.org, but I still get an error message from
CVS:

Waiting for Emacs...Done
Checking in index.html;
/cvs/nbbuild/www/index.html,v  <--  index.html
new revision: 1.7; previous revision: 1.6
done
Processing log script arguments...
Mailing the commit message to cvs@nbbuild.netbeans.org (from commitlogger)
U index.html
cvs [update aborted]: cannot rename file CleanAll.html to CVS/,,CleanAll.html:
Permission denied
Comment 5 jcatchpoole 2000-10-20 18:13:59 UTC
I have posted full details of my problems to dev@netbeans.org 3
times now.  Does anyone @ Collab read that list ?  This is quite
frustrating.

As I mentioned in an earlier email, the push of my edit to the look
module should coincide with some other plain www pushes I have waiting.
If at all possible please don't simply push my edits live ... not
sure how best to handle that.  Anyway, details again -

From within the look/ directory heirarchy, I attempted to do an update :

> [jcatchpoole@appsrv]: common $ cvs update
> cvs server: Updating .
> cvs server: cannot open directory /cvs/look/www/org/helm/common: No such
> file or directory
> cvs server: skipping directory

So I cd'ed right out, did rm -r look/, and did a fresh cvs checkout look.
I cd'ed back in, edited a file, and attempted to check it in -

> [jcatchpoole@appsrv]: common $ cvs commit T_Nav_Column.wm
> Checking in T_Nav_Column.wm;
> /cvs/look/www/org/tigris/helm/common/T_Nav_Column.wm,v  <--  T_Nav_Column.wm
> new revision: 1.31; previous revision: 1.30
> done
> Processing log script arguments...
> Mailing the commit message to cvs@look.netbeans.org (from commitlogger)
> ? org
> ? look-cvs
> cvs update: cannot open directory
> /usr/local/tigris/data/helm/cvs/repository/look/www/org/helm: No such file
> or directory

This edit did not go live on the site.

I repeated this whole procedure, ie removed my old look/ checked it out,
and went back in to do the same edit.  I found my first edit was already
there; ie the first checkin had worked, with the error above, but had
not been pushed live.

Today I attempted to update look/www/cvsweb/cvsweb.conf to fix a broken
link.  When I tried to checkin the fixed file, I got the following error :

[jcatchpoole@appsrv]: cvsweb $ cvs commit -m "fixing broken BSD link"
cvsweb.conf
Checking in cvsweb.conf;
/cvs/look/www/cvsweb/cvsweb.conf,v  <--  cvsweb.conf
new revision: 1.7; previous revision: 1.6
done
Processing log script arguments...
Mailing the commit message to cvs@look.netbeans.org (from commitlogger)
? org
? look-cvs
U cvsweb/cvsweb.conf
cvs update: cannot open
directory /usr/local/tigris/data/helm/cvs/repository/look/www/org/helm: No such
file or directory
cvs update: skipping directory org/helm
cvs [update aborted]: cannot rename file T_Nav_Column.wm to
CVS/,,T_Nav_Column.wm: Permission denied

Note one of these errors is in relation to T_Nav_Column.wm, the file I
first saw this problem with, on Monday.  I again did an rm -r look/ and
cvs checkout look, and again found my edit was correctly in place, but
not live.

Not sure if this is relevant but -
T_Nav_Column.wm now lives one directory level deeper than it did on the
old NB server, and I'm pretty sure on the new machine quite recently.
Specifically, it now appears to live in

look/www/org/tigris/helm/common/

whereas it used to be

look/www/org/helm/common/
Comment 6 jcatchpoole 2000-10-31 11:24:59 UTC
Seems to be fixed.  My previous edits are now live, and
tests to look/.../T_Nav_Column.wm and look/.../cvsweb.conf
work - ie no errors and are "live" immediately.
Comment 7 Unknown 2004-10-13 09:03:59 UTC
closing...
Comment 8 Marian Mirilovic 2009-11-08 02:26:53 UTC
We recently moved out from Collabnet's infrastructure


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo