Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 79519 - Solaris10/Linux/mac-Os:Wrong contextual menu items for any element on any diagram
Solaris10/Linux/mac-Os:Wrong contextual menu items for any element on any dia...
Status: VERIFIED FIXED
Product: uml
Classification: Unclassified
Component: General Diagram
5.x
All All
: P2 (vote)
: 6.x
Assigned To: Thuy.d Nguyen
issues@uml
UML_UST, HOL, release55_fixes_fixed
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-30 20:31 UTC by Peter Lam
Modified: 2007-05-11 14:59 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Lam 2006-06-30 20:31:36 UTC
Steps :
1. Create empty java project
2. Create java platform UML project, choose code gen and attach the java project
3. Create a class diagram and add a class element to it.
   Name the class
4. Bring up contextual menu on the class element
   You will observe the following menu items are missing :
   1. Generate code
   2. Navigate to source
   3. Generate dependency diagram
   4. Redefine operations

  These are displayed in windows environment, but are missing on solaris.

Comments [1]:
reproducible with coke_tpr2_rc1,
reproducible with any element if popup invoked without selection first.
popup has some items from opreviously selectd element and doesn't have some
items from invoked element.

Comments [2]:
reproducible with coke060503_6 on all unix like platforms,
it's a usabiity issue, I have to click on most elements twice to get expected
result.

Comments [3]:
during 8105 hol execution meet the issue several times/ added HOL keyword

Workaround:
select element first
invoke popup menu
Comment 1 Thuy.d Nguyen 2007-01-11 01:58:08 UTC
This issue still exists on Solaris (not on Windows) with griffin build on NB 5.5
FCS. 
The issue has an easy workaround as stated above, thus lowering the priority to P3.
Comment 2 Sergey Petrov 2007-03-01 15:30:57 UTC
Yes, but:
1) really annoying to do two clicks if know workaround instead of one click always
or more problems if invoked first with bad context because it may be hard to
click on element covered by context menu second time
2) greatly affects qe automation on non windows platforms
Comment 3 Peter Lam 2007-03-20 23:31:39 UTC
low use case not currently impacting our installed user base.
Comment 4 Thuy.d Nguyen 2007-04-12 12:51:17 UTC
Fixed and integrate to trunk.
Comment 5 Andrew Korostelev 2007-04-17 14:48:08 UTC
verified in all-nbms-griffin_fixes-070416_1-ml
on Opteron with Solaris 11
(hols testing system)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo