Bug 79453 - Syntax coloring schemes should also provide font anti-aliasing
Syntax coloring schemes should also provide font anti-aliasing
Status: RESOLVED WONTFIX
Product: editor
Classification: Unclassified
Component: Painting & Printing
-S1S-
All All
: P3 with 5 votes (vote)
: TBD
Assigned To: Miloslav Metelka
issues@editor
: UI
: 144516 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-29 21:08 UTC by seandynan
Modified: 2016-07-07 07:29 UTC (History)
3 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description seandynan 2006-06-29 21:08:55 UTC
I tend to switch editor schemes pretty frequently. Sometimes all I want is a
smaller font to maximise the amount of visible code. Other times I want a bigger
font because my eyes are straining after lengthy coding sessions.

Some fonts, for example ProFont (http://www.tobiasjung.net/profont/) and Windows
Courier New, really suck when anti-aliased. Most other fonts suck when they are
NOT anti-aliased.

Can we have the anti-aliasing option as part of the syntax coloring scheme
instead of global for the whole editor?

Thanks.
Comment 1 Vitezslav Stejskal 2008-08-21 14:48:33 UTC
Ondro, could you please think about this? We would probably need to have this in Tools-Options -> Fonts & Colors ->
Hightlights. Thanks
Comment 2 Ondrej Langr 2008-08-22 11:39:55 UTC
Highlights seem not to be a place where one would search for antialiasing. 

Logically, in the structure of current options, it belongs to the Font Chooser, but the problem is that there is a way
to set a separate font for various syntax elements, whereas antialiasing needs to be done per editor basis (thanks to
vstejskal for this info). However, none of our standard themes actually does set specific font. 

So, can the option be added to the font-chooser, but shared? I.e. if the option was turned off in the font-chooser for
default font and then file-chooser for "comment" was opened, it would "remember" the state. I know this means somewhat
obscuring the model from the user, but under normal circumstances it works as expected (Unless someone specifically
tries to set different antialiasing for different syntax elements, and even then it is rather easy to understand what
has happened). 

I'm not sure if this change actually can be done (possibly the font-chooser is the java one and cannot be tampered
with?). If not, the only way to address this enhancement is probably the "Text Antialiasing" option in Tools-Options ->
Fonts & Colors -> Highlights, but in that case, I would suggest not to address this at all because having
difficult-to-discover feature/option is about the same as having this feature/option not at all, maybe worse (it is
cluttering the UI).

I also tried some "non-conceptual" changes such as adding the option directly to the syntax panel, but it does not seem
to be the right approach considering majority of users are OK with anti-aliasing as it is. 
Comment 3 Vitezslav Stejskal 2008-09-05 13:08:32 UTC
*** Issue 144516 has been marked as a duplicate of this issue. ***
Comment 4 shadewind 2008-10-25 22:31:39 UTC
I believe an appropriate place for this would be Syntax tab directly or maybe Miscellaneous -> Appearance or perhaps
Editor section somewhere.

Add my vote.
Comment 5 Petr Somol 2012-01-25 16:45:23 UTC
Wiki page on anti-aliasing in NetBeans:
http://wiki.netbeans.org/FaqFontRendering
Comment 6 Martin Balin 2016-07-07 07:29:14 UTC
This old bug may not be relevant anymore. If you can still reproduce it in 8.2 development builds please reopen this issue.

Thanks for your cooperation,
NetBeans IDE 8.2 Release Boss


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo