Bug 79179 - Add a Branding Library
Add a Branding Library
Status: RESOLVED WONTFIX
Product: apisupport
Classification: Unclassified
Component: Project
5.x
All Linux
: P3 (vote)
: 5.x
Assigned To: Jesse Glick
issues@apisupport
: PLATFORM
: 79180 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-27 10:28 UTC by peterme2005
Modified: 2006-06-27 21:12 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description peterme2005 2006-06-27 10:28:08 UTC
Can we have a branding library such that we can give users of the software the
ability to change the branding of their given application. For example I want to
allow a user to change the splash screen, title bar icon, titlebar title and
perhaps even color schemes? Ideally id like this to sit under options i.e. Tools
-> Options -> Branding therefore perhpas linking this into the Options or SPI
library??

Thanks
Comment 1 Marian Mirilovic 2006-06-27 11:36:37 UTC
*** Issue 79180 has been marked as a duplicate of this issue. ***
Comment 2 Jesse Glick 2006-06-27 21:12:06 UTC
No plans to implement anything of the sort in the platform. The design point is
branding customized by the application creator, not the end user. That said,
some of these things can be made customizable by a user if you write the support
for it. E.g. for color schemes, search for docs on NbTheme (applies only to Java
L&F, not native L&Fs). Window title can be modified by using reflective calls to
window system impl (cf. Hacks.java in projects/projectui). Use
dev@openide.netbeans.org for help but be aware some things will not be possible.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo