Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 79177 - Mapper is not opened automatically when selecting assignments
Mapper is not opened automatically when selecting assignments
Status: VERIFIED FIXED
Product: soa
Classification: Unclassified
Component: BPEL Mapper
5.x
All All
: P2 (vote)
: 5.x
Assigned To: Joshua Sandusky
issues@soa
55EP_BETA_WAIVED EP55_BETA_FAQ
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-27 09:52 UTC by Mikhail Kondratyev
Modified: 2006-08-29 10:43 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mikhail Kondratyev 2006-06-27 09:52:33 UTC
Steps to reproduce:
 - create a Sync BPEL process, open process in designer
 - select the assignment activity
BPEL mapper window will no be opened. This is a serious usability issue as there
is no indication what window needs to be opened for assignments management.
There is also no context menu item on the activities to open the mapper
Comment 1 Jiri Kopsa 2006-06-27 15:44:04 UTC
Ultimately the BPEL Mapper window should appear automatically when BPEL editor
is opened or gets focused, unless it was closed explicitly by the user before.

This issue is related to the issue #78066 (same UI pattern):
http://www.netbeans.org/issues/show_bug.cgi?id=78066
Comment 2 Joshua Sandusky 2006-07-21 20:22:43 UTC
*** Issue 80216 has been marked as a duplicate of this issue. ***
Comment 3 Joshua Sandusky 2006-07-27 00:25:16 UTC
fixed, the bpel mapper is now part of the bpel editor window group, and will
open/close accordingly.
Comment 4 lchang 2006-08-03 22:29:46 UTC
This looks great!

When you first open BPEL Editor, you just have the Orchestrator.
1.  If you create an Assign, While, ForEach, RepeatUntil or any other activity 
that requires a mapping, the mapper will open.
2.  If you click on an activity that doesn't require mapping, the mapper will 
close.
3.  If you explicitly close the BPEL Mapper, the mapper will remain closed.
4.  If you explicitly open the BPEL Mapper, the mapper will follow the rules of 
#1 and #2.
Comment 5 Joshua Sandusky 2006-08-11 01:11:06 UTC
I actually found a bug where the mapper does not initially open if the mapper
module was not initialized. This was probably caused by my removal of the
ModuleInstall, which pre-loads the mapper module before the bpel editor ever opens.

Instead of pre-loading the mapper upon module install, I need to create a
service provider interface in the bpel editor, and then implement that interface
in the mapper. Thus, the bpel editor can load the mapper when it needs to.
Currently, the mapper does not get loaded by the bpel editor, and instead must
be explicitly opened from the menu before its window grouping auto-open/close
capabilities become operable.
Comment 6 Joshua Sandusky 2006-08-17 01:12:37 UTC
the mapper window group now automatically opens, without the need for the
ModuleInstall mechanism. The mapper implements a service provider interface in
the bpel editor to accomplish the same, yet in a smarter way
Comment 7 Mikhail Kondratyev 2006-08-29 10:43:26 UTC
Verified in build from 06.08.25


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo