Bug 79173 - Lack of synchronization in JMManager.waitScanFinished() and JMManager.isScanInProgress()
Lack of synchronization in JMManager.waitScanFinished() and JMManager.isScanI...
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: Unsupported
5.x
All All
: P3 (vote)
: 6.x
Assigned To: issues@java
issues@java
: THREAD
Depends on:
Blocks: 74692
  Show dependency treegraph
 
Reported: 2006-06-27 09:08 UTC by Andrei Badea
Modified: 2007-09-26 09:14 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrei Badea 2006-06-27 09:08:25 UTC
The JMManager methods waitScanFinished() and isScanInProgress() are not
synchronized. See the discussion in issue 74692. The reason for avoiding
synchronization mentioned in that issue, that is avoiding deadlocks, is not a
valid one. Lack of synchronization can cause random bugs which are hard to
reproduce and debug.
Comment 1 Jan Becicka 2006-10-26 16:26:34 UTC
Javacore module was replaced by Retouche infrastructure. This bug is not valid
in trunk any more.
Comment 2 Quality Engineering 2007-09-20 09:45:06 UTC
Reorganization of java component


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo