Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 7881 - New Class Wizard should check if the class name is unique before continuing
New Class Wizard should check if the class name is unique before continuing
Status: CLOSED FIXED
Product: platform
Classification: Unclassified
Component: Window System
3.x
All All
: P3 (vote)
: 3.x
Assigned To: David Strupl
issues@platform
:
: 11324 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-11 23:45 UTC by jhoffman
Modified: 2008-12-22 17:57 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jhoffman 2000-10-11 23:45:57 UTC
If you enter a class name that already exists in the New Class wizard, you will
not get any indication until you have completed the wizard and then you get a
message that says the class name already exists.  This message does not allow
you to return to the wizard to change the class name so all your work is *lost*.

Clicking the Next button after specifying the class name should check if that
name is unique, if not, post a message and allow the user to change the name
before continuing.
Comment 1 Pavel Buzek 2000-11-23 17:59:59 UTC
it does not apply only to Java class, but also for other templates
Comment 2 David Strupl 2000-11-24 12:38:59 UTC
Fixed in the main trunk.
Comment 3 David Strupl 2000-11-24 15:55:59 UTC
Fixed in the release31.
Comment 4 Mike Schilling 2001-04-11 22:10:35 UTC
There is a case in which the check isn't done correctly.  See issue 11324 for 
details.
Comment 5 Mike Schilling 2001-04-11 22:14:35 UTC
*** Issue 11324 has been marked as a duplicate of this issue. ***
Comment 6 David Strupl 2001-04-13 17:50:42 UTC
Pasting the description from the duplicate here:

Create the test object in the root of a filesystem.
Now try to create the duplicate:
1. Bring up the wizard from File->New (not with right-click)
2. Choose the object type, hit next
3. Enter the name of the same-named object and indicate the root of the
filesystem as the target location.
4. Next is grayed out at this point.
5. Hit the back button to see the template selection page.
6. Hit Next again.
7. Now Next is (incorrectly) enabled and you hit the bug.

The validity check is not done after move from templates panel
to targetPanel.
Comment 7 David Strupl 2001-04-13 17:52:17 UTC
Changing version and making it P3 - the steps are quite rare.
Comment 8 David Strupl 2001-04-23 15:28:08 UTC
Fixed in both [dev] and [release32].
Comment 9 Jan Chalupa 2001-05-05 20:51:01 UTC
Target milestone 3.2
Comment 10 Jan Zajicek 2001-05-21 14:22:28 UTC
verified
Comment 11 Quality Engineering 2003-07-01 16:36:01 UTC
Resolved for 3.4.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo