Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 7874 - Opening a java file (with an associated form) caused the java file to appear modified
Opening a java file (with an associated form) caused the java file to appear ...
Status: CLOSED WONTFIX
Product: guibuilder
Classification: Unclassified
Component: Code
3.x
PC Windows 3.1/NT
: P4 (vote)
: TBD
Assigned To: issues@guibuilder
issues@guibuilder
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-11 22:47 UTC by jhoffman
Modified: 2003-06-30 18:25 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jhoffman 2000-10-11 22:47:45 UTC
When opening a form file, the editor window opens with the Java code and it
appears with an "*" inidicating that the file has been modified.  If I close
the editor I am asked if I want to change this file, but I have made no edits
to it, so I am puzzled as to why I was asked.

This is a problem when using source control, since CVS (for example) will mark
the file as "locally modified" if I save the file just to get the save dialog
out of my way.
Comment 1 Tomas Pavek 2000-10-12 09:32:59 UTC
Form code generator may produce slightly different code between builds due to
changes in formatting implementation (e.g. indentation engine) or properties
settings in options. Form opened in the same build as it was saved should not
be marked modified.
However, you need not save the form if you did no changes - meaning of the
source code should be same (if generated parts were not modifed externally).


*** This bug has been marked as a duplicate of 5957 ***
Comment 2 Quality Engineering 2003-06-30 18:20:58 UTC
Resolved for 3.3.x or earlier, no new info since then -> closing.
Comment 3 Quality Engineering 2003-06-30 18:25:59 UTC
Resolved for 3.3.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo