Bug 78591 - UML sample BankApp integration in IDE
UML sample BankApp integration in IDE
Status: VERIFIED FIXED
Product: uml
Classification: Unclassified
Component: Project
5.x
PC Windows XP
: P1 (vote)
: 6.x
Assigned To: Craig Conover
issues@uml
:
: 104761 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-20 13:30 UTC by bugbridge
Modified: 2007-07-14 00:32 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bugbridge 2006-06-20 13:30:39 UTC
Description:
dev. engineers needs to integrate the BankApp sample base on BPEL samples so
sample uml project can be created.
Comment 1 George Vasick 2007-05-25 16:58:52 UTC
Needs to be integrated by the feature freeze.
Comment 2 George Vasick 2007-05-25 17:01:01 UTC
*** Issue 104761 has been marked as a duplicate of this issue. ***
Comment 3 Craig Conover 2007-06-14 07:49:53 UTC
Adding a new module project to the uml cluster for UML samples. Converting existing UML Bankapp Sample module to use UML
project generator which it could not do in previous release due to dependency restrictions.
Comment 4 Peter Lam 2007-06-22 00:57:53 UTC
Please make sue UML is in the correct sample order in the New Project Wizard per the following excerpt from the ui spec.

Samples
    Java
    Web
    Enterprise
    Mobility
    UML
    SOA
    Ruby ???
    NetBeans Plugin Modules
    Java BluePrints Solutions
Comment 5 Craig Conover 2007-07-03 01:11:46 UTC
New module added to UML cluster for this and future UML samples which can leverage the UML APIs (unlike in v5.5)

UML bank app sample is now generated fresh instead of using a pre-packaged sample uml project which had flaky behavior
with sharing diagrams across all sample uml projects.

All diagrams in the sample app must be manually created. Readme file is updated noting this.
Comment 6 Peter Lam 2007-07-10 02:35:48 UTC
verified in build netbeans-hudson-trunk-1546-full.zip

Just one minor thing. In step 5 of the README file, the 2nd "Creating the BankAccountDependencies diagram:" should be
something like "Creating the withdraw sequence diagram". So, I'm re-opening this issue for this is. If a new issue
should be filed, let me know.
Comment 7 Craig Conover 2007-07-12 22:40:16 UTC
Fixed typo.
Comment 8 Peter Lam 2007-07-14 00:30:19 UTC
verified in build netbeans-hudson-trunk-1707-full.zip (070713)
Comment 9 Peter Lam 2007-07-14 00:32:03 UTC
related issue 109473.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo