Bug 78422 - MacOS: Can't work with Projects TAB after RE UML project is created
MacOS: Can't work with Projects TAB after RE UML project is created
Status: VERIFIED FIXED
Product: uml
Classification: Unclassified
Component: Project
5.x
All Mac OS X
: P1 (vote)
: TBD
Assigned To: Kris Richards
issues@uml
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-19 23:56 UTC by bugbridge
Modified: 2006-10-06 12:27 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bugbridge 2006-06-19 23:56:06 UTC
Original status: 1-Dispatched; Suggested Status: NEW

Original submitter: akorostelev

Description:
Reproduced on Coke TPR2 RC1 on MacOS.
After RE UML project is created, Exception rises on any action in Projects tab.
It is possible to continue work only after JSE restart.

Type of exception is:
java.lang.ClassCastException: sun.java2d.NullSurfaceData

How to reproduce:
- Create simple java project with default parameters and default Main class.
- Wait 'Scanning Project Classpath' action to be finished.
- create new UML project of 'Java-Platform Model by Reverse-Engineering a Java
Project' type based on recently created java project.
- press 'Done' button in 'Reverse Engineering' status dialog.

try to expant Model node in Project tree... 
Then try to expand another tree...
Try to scroll Projects tab.

Any action results in Exception without performing action. Attempt to repeat the
same action has no result...
New Action results in the same type of exception with new StackTrace.

Two Exception Examples:
----------------example 1-----------------

java.lang.ClassCastException: sun.java2d.NullSurfaceData
	at apple.laf.AquaImageFactory.drawTreeArrow(AquaImageFactory.java:663)
	at apple.laf.AquaTreeUI.paintExpandControl(AquaTreeUI.java:261)
	at javax.swing.plaf.basic.BasicTreeUI.paint(BasicTreeUI.java:1178)
	at apple.laf.AquaTreeUI.paint(AquaTreeUI.java:122)
	at javax.swing.plaf.ComponentUI.update(ComponentUI.java:154)
	at javax.swing.JComponent.paintComponent(JComponent.java:740)
	at javax.swing.JComponent.paint(JComponent.java:1003)
	at org.openide.explorer.view.TreeView$ExplorerTree.access$1101(TreeView.java:1395)
	at org.openide.explorer.view.TreeView$ExplorerTree.guardedPaint(TreeView.java:1529)
	at org.openide.explorer.view.TreeView$ExplorerTree.access$1400(TreeView.java:1395)
	at
org.openide.explorer.view.TreeView$ExplorerTree$GuardedActions.run(TreeView.java:1809)
	at org.openide.util.Mutex.readAccess(Mutex.java:221)
	at
org.openide.explorer.view.TreeView$ExplorerTree$GuardedActions.<init>(TreeView.java:1803)
	at org.openide.explorer.view.TreeView$ExplorerTree.paint(TreeView.java:1506)
	at javax.swing.JComponent._paintImmediately(JComponent.java:4848)
	at javax.swing.JComponent.paintImmediately(JComponent.java:4634)
	at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:477)
[catch] at
javax.swing.SystemEventQueueUtilities$ComponentWorkRequest.run(SystemEventQueueUtilities.java:114)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:461)
	at
java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:267)
	at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:196)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:190)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:182)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)


----------------example 2-----------------
java.lang.ClassCastException: sun.java2d.NullSurfaceData
	at apple.laf.AquaImageFactory.drawTreeArrow(AquaImageFactory.java:663)
	at apple.laf.AquaTreeUI.paintExpandControl(AquaTreeUI.java:261)
	at
apple.laf.AquaTreeUI$TreeArrowMouseInputHandler.paintOneControl(AquaTreeUI.java:431)
	at
apple.laf.AquaTreeUI$TreeArrowMouseInputHandler.mouseReleased(AquaTreeUI.java:393)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:232)
	at java.awt.Component.processMouseEvent(Component.java:5562)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3093)
	at java.awt.Component.processEvent(Component.java:5327)
	at java.awt.Container.processEvent(Container.java:2010)
	at java.awt.Component.dispatchEventImpl(Component.java:4029)
	at java.awt.Container.dispatchEventImpl(Container.java:2068)
	at java.awt.Component.dispatchEvent(Component.java:3877)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4256)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:3936)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:3866)
	at java.awt.Container.dispatchEventImpl(Container.java:2054)
	at java.awt.Window.dispatchEventImpl(Window.java:1766)
	at java.awt.Component.dispatchEvent(Component.java:3877)
[catch] at java.awt.EventQueue.dispatchEvent(EventQueue.java:463)
	at
java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:267)
	at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:196)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:190)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:182)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)

Workaround:
restarting ide seems to work ok. Minimize and restore ide also works.

Comments:
It is unknown if it is a REGRESSION or not,
because it is not possible to check buzz and Coco on MacOS now...

Projects tab doesn't reflect on any actions, but without any exception,  
on the following configuration:
OS version: 10.4.5
JDK version 1.5.0_06

The same result after using 'Update Model From Source' for just related projects.
Comment 1 Kris Richards 2006-09-21 19:09:40 UTC
fixed as a result of the rev eng work.
Comment 2 Sergey Petrov 2006-10-06 12:27:17 UTC
verified with nb061002+uml?061006?


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo