Bug 78418 - MAC: There is no project tree in web report in Safari
MAC: There is no project tree in web report in Safari
Status: CLOSED FIXED
Product: uml
Classification: Unclassified
Component: Reporting
5.x
All Mac OS X
: P1 (vote)
: 5.x
Assigned To: issues@uml
issues@uml
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-19 23:49 UTC by bugbridge
Modified: 2006-08-31 02:29 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bugbridge 2006-06-19 23:49:17 UTC
Original status: 1-Dispatched; Suggested Status: NEW

Original submitter: sergeyp

Description:
reproducible with coke_tpr2 on mac-osx-10.4.5/java1.5.06
safari 2.0.3(417.8) - default browser

steps to reproduce:
1. create java platform uml project
2. add package with scoped class diagram
3. add class and name
4. generate web report (default)
5. press done oin wizard
safari is opened and only welcome page is available, there is no project tree in
left frame.

Evaluation:
Looks like the problem is with Safari browser. I tarred up the webreport
directory and ftp'ed to solaris and I could view the web report fine on Mozilla
1.7. I then downloaded and installed Mozilla 1.7 on the Mac system and able to
open and view the web report fine too. So, this issue might be related to CR
6305856 on other platforms.
Comment 1 Yang Su 2006-06-23 19:59:44 UTC
It was caused by the incompatibility of the javascript used to display the
project tree and the Safari browser support.

Now the report has changed to use javadoc style to organize model information,
left hand navigation does not require any javascripting, we essentially avoid
those issues that are out of our control.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo