Bug 78311 - a11y: tab key does not navigate to the next node or element on the diagram
a11y: tab key does not navigate to the next node or element on the diagram
Status: VERIFIED FIXED
Product: uml
Classification: Unclassified
Component: General Diagram
5.x
PC Windows XP
: P1 (vote)
: TBD
Assigned To: _ jyothivasa
issues@uml
Keyboard Access
: A11Y
: 80738 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-19 21:28 UTC by bugbridge
Modified: 2006-11-07 14:58 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bugbridge 2006-06-19 21:28:53 UTC
Original status: 1-Dispatched; Suggested Status: NEW

These items should be added to the Keywords: A11Y
Original submitter: petersl

Description:
Coke TPR2/Coco/Buzz

With an element selected in the diagram window, pressing the Tab key should
navigate to the next element or node in the diagram.

Description (Entry 2):
online help should be updated to include this info.
Comment 1 Andrew Korostelev 2006-08-25 13:59:22 UTC
*** Issue 80738 has been marked as a duplicate of this issue. ***
Comment 2 Andrew Korostelev 2006-08-25 14:00:50 UTC
from issue 80738 that has been marked as a duplicate of this issue:

to select any elemnt on diagram user have to switch to project tree on first
step event if there are few elemnts and it can be easy to select them with TAB, 
there is no way to select first elemnt two if diagram has focus and no elemnts
is selected
Comment 3 Andrew Korostelev 2006-08-29 10:58:28 UTC
see also issue 78348
Comment 4 Peter Lam 2006-10-05 22:18:08 UTC
Broken focus traversal
Comment 5 _ jyothivasa 2006-11-02 01:49:39 UTC
Use tab/shift-tab to cycle between nodes
Use Shift Up/Down arrows to cycle between the edges of a node
Bring up context menu and, Find--Source/target element to navigate to the
source/target nodes of an edge.
Comment 6 Sergey Petrov 2006-11-02 13:33:21 UTC
navigation doesn't continue after edge selection:
- use shift+up to go to edge and try tab after the action, nothing happens 
(if it will be within appropriate time to implement it's good to start order
from last selected element in this case, not from the beginning)
Comment 7 _ jyothivasa 2006-11-02 19:23:55 UTC
Once you are on an edge, to continue traversing with the nodes, you need to
either go to source node or the target node of the edge (context menu, find -
source/target), and then continue cycling through nodes using tab. The main
reason was to reduce the overhead of knowing from which direction you came to
the edge.
Comment 8 Sergey Petrov 2006-11-03 09:24:36 UTC
ok, this one seems fixed, I'll file another one on a11y unexpected
behavior/usability because some links may have no visible direction, we have
also bug for reverse direction of activity edges and it may lead to much more
steps to return to initial element and may be continue tab order.
Comment 9 Andrew Korostelev 2006-11-07 14:58:45 UTC
verified in ide-coco-061106_9
new related issues will be filed for incorrectly supported cases.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo