Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 78195 - [55cat] Alignment and Distribution Tools/Options of objects
[55cat] Alignment and Distribution Tools/Options of objects
Status: VERIFIED FIXED
Product: uml
Classification: Unclassified
Component: General Diagram
5.x
All All
: P2 with 1 vote (vote)
: 6.x
Assigned To: Craig Conover
issues@uml
EXT-USER
:
Depends on:
Blocks: 98849
  Show dependency treegraph
 
Reported: 2006-06-16 22:50 UTC by bugbridge
Modified: 2007-04-10 08:48 UTC (History)
3 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bugbridge 2006-06-16 22:50:17 UTC
Original Target Release: coke_dev; Suggested Target Milestone : 5.5

Description:
--------------------------------
Currently, you have to manually align and distribute objects.
It would be a nice option to have a couple of toolbar icons to align the
objects, such as align bottom, align right, align center to page, distribute
bottom, distribute spacing vertically, etc. etc. etc. 
Or maybe a grid and a snap to grid option.
Comment 1 Sergey Petrov 2006-07-04 12:25:58 UTC
updating priority, there was P2 rfe for previous release,
additional way to get good result(of cause not easiest) is to add possibility to
enter element sizes and positions in elent properties,
There was match sizes tool in initial rewuest also.
Comment 2 Sergey Petrov 2006-09-07 08:56:35 UTC
*** Issue 84365 has been marked as a duplicate of this issue. ***
Comment 3 brviking 2006-09-07 15:15:14 UTC
Added [55cat] to track on dashboard, and myself to CC (due duplicate issue).
Comment 4 Andrew Korostelev 2007-02-14 13:14:43 UTC
more special case for sequence diagram - issue 95543
Comment 5 Craig Conover 2007-03-09 01:46:20 UTC
- first checkin of alignment tools (no distribution tools yet): left, right,
center (horiz/vert), top, bottom. Uses first selected element as the reference
point.
- align tools are accessible via right click context menu (toolbar buttons are
planned)
Comment 6 Craig Conover 2007-03-10 03:15:46 UTC
Added distribution functionality: distribute horizontally to Left Edge, Center,
and Right Edge; and distribute vertically to Top Edge, Center and Bottom Edge.

Actions are accessible via right mouse click context menu. Distribute submenu
has the 6 distribute actions. 

Toolbar buttons should be added for these and still need A11Y functionality.
Comment 7 Craig Conover 2007-03-23 20:23:09 UTC
The alignment and distribution tools are available via the context menu for the
selected elements on a diagram so this feature is "fixed". The toolbar buttons
work has been put in its own issue 98849.
Comment 8 Sergey Petrov 2007-04-10 08:30:21 UTC
initial issue say about toolbar buttons which is more common way to implement
the functionality
second comment say about match size tool also, but I can file separate enhancement
Comment 9 Sergey Petrov 2007-04-10 08:47:21 UTC
ok, found issue 98849
Comment 10 Sergey Petrov 2007-04-10 08:48:51 UTC
let this one be fixed


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo