Bug 78172 - cannot add correlation set
cannot add correlation set
Status: VERIFIED FIXED
Product: soa
Classification: Unclassified
Component: BPEL
5.x
All Windows XP
: P1 (vote)
: 5.x
Assigned To: Nikita Krjukov
issues@soa
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-16 16:10 UTC by bugbridge
Modified: 2006-10-02 13:26 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
exception stack trace (1.12 KB, application/x-compressed)
2006-06-16 16:12 UTC, Andrey Yamkovoy
Details
bpel (31.21 KB, application/x-compressed)
2006-06-16 16:12 UTC, Andrey Yamkovoy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bugbridge 2006-06-16 16:10:10 UTC
Description:
Prerequisite:
1.  Unzip attached document to local directory

Steps to reproduce:
1.  Create new BPEL Module
2.  Right-click BPEL Module > Source Packages.
3.  Select "Retrieve Schema and WSDL Documents"
4.  Point Source Folder to the file you unzipped ..\InsuranceClaimBpel\src
5.  Modify the Save to Folder to: C:\Documents and
Settings\lchang\InsuranceClaimBP\src
6.  Create a new .bpel file.
7.  Import the Wrapper.wsdl file.
8.  In the Navigator, right-click Correlation Sets and select, Add Correlation Set

Result:  You will get an "Unexpected Exception".  (see attached exception.txt
for more information)

Workaround:
Go into the source and modify the source to: 

   <correlationSets>
        <correlationSet name="CorrelationSet1"/>
        <correlationSet name="ClaimNumber" properties="ns1:claimNumberProperty"/>
    </correlationSets>
Comment 1 Andrey Yamkovoy 2006-06-16 16:12:12 UTC
Created attachment 31126 [details]
exception stack trace
Comment 2 Andrey Yamkovoy 2006-06-16 16:12:44 UTC
Created attachment 31127 [details]
bpel
Comment 3 Nikita Krjukov 2006-07-07 13:08:21 UTC
It must be fixed already as a result of latest improvements of code. 
So now I can't reproduce the defect. 
BTW, there isn't an attached WSDL file as it described. But I tried to load the 
attached project. Correlation Set works fine there. 
Comment 4 Alexander Pepin 2006-10-02 13:26:58 UTC
No way to reproduce the bug because of drastic changes in bpel UI.
verified in build 061001


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo