Bug 78152 - Exception when performing double click on the Invoke and Reply elements
Exception when performing double click on the Invoke and Reply elements
Status: VERIFIED FIXED
Product: soa
Classification: Unclassified
Component: BPEL
5.x
PC Windows XP
: P1 (vote)
: 5.x
Assigned To: Nikita Krjukov
issues@soa
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-16 15:33 UTC by bugbridge
Modified: 2006-08-31 02:00 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bugbridge 2006-06-16 15:33:39 UTC
Steps to reproduce:
 - create a BPEL module
 - open BPEL in designer
 - add an Invoke activity (or Reply activity) from palette
 - double click on the Invoke element 
Exception will be thrown:
Annotation: Missing resource from class:
org/netbeans/modules/bpel/properties/editors/Form_ru_RU
Annotation: Key which was not found: 
java.util.MissingResourceException: Can't find bundle for base name
org/netbeans/modules/bpel/properties/editors/Form, locale ru_RU
	at java.util.ResourceBundle.throwMissingResourceException(ResourceBundle.java:837)
	at java.util.ResourceBundle.getBundleImpl(ResourceBundle.java:727)
	at java.util.ResourceBundle.getBundle(ResourceBundle.java:550)
	at
org.netbeans.modules.bpel.properties.editors.InvokeMainPanel.initComponents(InvokeMainPanel.java:87)
	at
org.netbeans.modules.bpel.properties.editors.InvokeMainPanel.createContent(InvokeMainPanel.java:35)
	at
org.netbeans.modules.bpel.properties.editors.InvokeMainPanel.<init>(InvokeMainPanel.java:31)
	at
org.netbeans.modules.bpel.properties.editors.InvokeCustomEditor.createContent(InvokeCustomEditor.java:47)
	at
org.netbeans.modules.bpel.properties.editors.InvokeCustomEditor.<init>(InvokeCustomEditor.java:35)
	at
org.netbeans.modules.bpel.properties.nodes.InvokeNode.getCustomizer(InvokeNode.java:112)
	at
org.netbeans.modules.bpel.properties.PropertyNodeFactory.showNodeCustomEditor(PropertyNodeFactory.java:325)
	at
org.netbeans.modules.bpel.navigator.nodes.NavigatorNodeFactory.showNodeCustomEditor(NavigatorNodeFactory.java:133)
	at
org.netbeans.modules.bpel.design.DesignView.showCustomEditor(DesignView.java:344)
	at
org.netbeans.modules.bpel.design.MouseHandler.mouseClicked(MouseHandler.java:102)
	at java.awt.AWTEventMulticaster.mouseClicked(AWTEventMulticaster.java:211)
	at java.awt.AWTEventMulticaster.mouseClicked(AWTEventMulticaster.java:211)
	at java.awt.Component.processMouseEvent(Component.java:5491)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3126)
	at java.awt.Component.processEvent(Component.java:5253)
	at java.awt.Container.processEvent(Container.java:1966)
	at java.awt.Component.dispatchEventImpl(Component.java:3955)
	at java.awt.Container.dispatchEventImpl(Container.java:2024)
	at java.awt.Component.dispatchEvent(Component.java:3803)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4212)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:3901)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:3822)
	at java.awt.Container.dispatchEventImpl(Container.java:2010)
	at java.awt.Window.dispatchEventImpl(Window.java:1774)
	at java.awt.Component.dispatchEvent(Component.java:3803)
[catch] at java.awt.EventQueue.dispatchEvent(EventQueue.java:463)
	at
java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:242)
	at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:163)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:157)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:149)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)
Comment 1 Nikita Krjukov 2006-07-07 12:48:34 UTC
I can't reproduce the issue.
Comment 2 Mikhail Kondratyev 2006-07-24 14:15:30 UTC
Verified in build from 060723


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo