Bug 78121 - "Diff" doesn't get updated if "TestCase(Diff)" window is opened already.
"Diff" doesn't get updated if "TestCase(Diff)" window is opened already.
Status: CLOSED FIXED
Product: soa
Classification: Unclassified
Component: JBI Test Driver
5.x
PC Windows XP
: P1 (vote)
: 5.x
Assigned To: Jun Qian
issues@soa
:
: 80787 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-16 15:12 UTC by bugbridge
Modified: 2006-08-31 02:01 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bugbridge 2006-06-16 15:12:40 UTC
Original status: 1-Dispatched; Suggested Status: NEW

These items should be added to the Status Whiteboard: HOL
Original submitter: hong_lin

Description:
Build: Coke TPR3 and nightly build 060530

Steps to reproduce it:

1. Create SynchronousSample project.
2. Edit output.xml file under Test/TestCase0. Add some space between "Hello" and
"World", so line 6 will be "      <paramA>Hello    World</paramA>"
3. Run TestCase0. Test fail. 
4. Select TestCase0, right-click, select "Diff" from context menu.
See attached snapshot test1.bmp file.

5. repeat step 3 and 4.
See attached snapshot test2.bmp file. The "TestCase0(Diff)" is not updated.

6. Close "TestCase(Diff)" file in the Editor window.
7. Repeat step 3 and 4.
See attached snapshot test3.bmp file.  The "TestCase0(Diff)" is updated.
Comment 1 Jun Qian 2006-07-21 20:45:15 UTC
*** Issue 80787 has been marked as a duplicate of this issue. ***
Comment 2 Jun Qian 2006-07-23 22:33:21 UTC
Fixed. Auto refresh diffs when new test is run.
Comment 3 vmalapati 2006-07-26 11:26:04 UTC
Able to reproduce the same on Build Build060724. Hence the ticket is reopened.
Comment 4 Jun Qian 2006-07-26 22:17:55 UTC
The fix I made in 7/24 had some typo, which was corrected on 7/25. Therefore, it
should be working in Build060725.
Comment 5 _ hong_lin 2006-07-26 23:04:17 UTC
Verified the bug is fixed in build 060725.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo