Bug 78118 - It's impossible to create assignment with element of 'Property' type
It's impossible to create assignment with element of 'Property' type
Status: VERIFIED INVALID
Product: soa
Classification: Unclassified
Component: BPEL
5.x
PC Windows XP
: P1 (vote)
: 5.x
Assigned To: issues@soa
issues@soa
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-16 15:10 UTC by bugbridge
Modified: 2006-08-31 02:00 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bugbridge 2006-06-16 15:10:28 UTC
Description:
Steps to reproduce:
- Create new orchestration project and open bpel multy-view editor.
- Add Assign pattern to process and call its property editor.
- Push Add button.
- Set 'From' or 'To' type to value 'Property'.
- Push corresponding '...' button to call Property Chooser.
- Noticed that there are no dialog appeared.

Evaluation:
Ok this case of "Variable + Property" is supposed to be supported according to
BPEL Spec.

<from variable="ncname" property="qname"/>

<to variable="ncname" property="qname"/>

However, this is not that significant an assigment. The same can be achieved
Variable/Part/Query assignements.

We do not have time to implement a proper Variable - Property editor, so we are
recommending that for TPR2 we modify the Assignment editor to eliminate the
"Property" choice from both the "From" and the "To" lists.

Suggested Fix:
see evaluation.
Comment 1 Nikita Krjukov 2006-07-20 16:36:38 UTC
The issue is not under my responsibility for a long time. 
All assignments now processed by the BPEL Mapper. 
Also as I know, the feature isn't supported neither by runtime nor by mapper.
Comment 2 Michael Frisino 2006-07-21 10:38:53 UTC
This bug was logged against older TPR. In current IDE we do not support
assignments of type property so this is non issue.
Comment 3 Mikhail Kondratyev 2006-07-24 13:47:03 UTC
Verified in build from 060723


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo