Bug 78090 - java.lang.AssertionError Exception if select Refactor -> Rename for <default package>
java.lang.AssertionError Exception if select Refactor -> Rename for <default ...
Status: VERIFIED FIXED
Product: soa
Classification: Unclassified
Component: BPEL Project
5.x
PC Windows XP
: P1 (vote)
: 5.x
Assigned To: Sreenivasan Genipudi
issues@soa
:
: 79317 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-16 14:40 UTC by bugbridge
Modified: 2006-10-02 08:48 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Bpel and compapp project source packages default packages having java refactoring enabled (262.50 KB, application/octet-stream)
2006-07-18 21:55 UTC, Ritesh Adval
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bugbridge 2006-06-16 14:40:52 UTC
Original status: 1-Dispatched; Suggested Status: NEW

Original Target Release: coke_dev; Suggested Target Milestone : 5.5

Original submitter: hong_lin

Description:
Build: Coke nightly build 060529

Steps to reproduce:

1. Create a BPEL project BpelModule1.
2. Expand BpelModule1 -> Source Packages.
3. Right-click "<default package>" node, select Refactor->Rename.

Will get the following exception.

java.lang.AssertionError: JavaModel.getJavaExtent(C:/Documents and
Settings/Hong/BpelModule1/src) returned null
	at
org.netbeans.modules.refactoring.ui.RenameAction.createRefactoringUI(RenameAction.java:108)
	at
org.netbeans.modules.refactoring.spi.ui.AbstractRefactoringAction.run(AbstractRefactoringAction.java:174)
	at
org.netbeans.modules.refactoring.spi.ui.AbstractRefactoringAction$1.run(AbstractRefactoringAction.java:71)
	at
org.netbeans.modules.javacore.internalapi.JavaMetamodel.invokeAfterScanFinished(JavaMetamodel.java:209)
	at
org.netbeans.modules.refactoring.spi.ui.AbstractRefactoringAction.performAction(AbstractRefactoringAction.java:74)
	at org.openide.util.actions.NodeAction.performAction(NodeAction.java:255)
	at
org.openide.util.actions.CallableSystemAction$1.run(CallableSystemAction.java:94)
	at
org.netbeans.modules.openide.util.ActionsBridge.doPerformAction(ActionsBridge.java:47)
	at
org.openide.util.actions.CallableSystemAction.actionPerformed(CallableSystemAction.java:90)
	at org.openide.util.actions.NodeAction.actionPerformed(NodeAction.java:244)
	at
org.netbeans.modules.refactoring.spi.ui.AbstractRefactoringAction.access$101(AbstractRefactoringAction.java:42)
	at
org.netbeans.modules.refactoring.spi.ui.AbstractRefactoringAction.actionPerformed(AbstractRefactoringAction.java:82)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1849)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2169)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:420)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:258)
	at javax.swing.AbstractButton.doClick(AbstractButton.java:302)
	at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:1000)
	at
javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:1041)
	at java.awt.Component.processMouseEvent(Component.java:5488)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3126)
	at java.awt.Component.processEvent(Component.java:5253)
	at java.awt.Container.processEvent(Container.java:1966)
	at java.awt.Component.dispatchEventImpl(Component.java:3955)
	at java.awt.Container.dispatchEventImpl(Container.java:2024)
	at java.awt.Component.dispatchEvent(Component.java:3803)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4212)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:3892)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:3822)
	at java.awt.Container.dispatchEventImpl(Container.java:2010)
	at java.awt.Window.dispatchEventImpl(Window.java:1774)
	at java.awt.Component.dispatchEvent(Component.java:3803)
[catch] at java.awt.EventQueue.dispatchEvent(EventQueue.java:463)
	at
java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:242)
	at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:163)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:157)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:149)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)
Comment 1 Michael Frisino 2006-07-16 21:29:44 UTC
I assume this is side effect of the BPEL project usage of Java package
structure. I thought that project team was going to move to simple folder style
in which case this would not be an issue.
Comment 2 Michael Frisino 2006-07-16 22:08:27 UTC
*** Issue 79317 has been marked as a duplicate of this issue. ***
Comment 3 Jun Qian 2006-07-17 21:17:02 UTC
In the CompApp Project design meeting With Jiri and Todd, I don't think we have
agreed on moving to a simple folder style. I don't know what's the agreement in
BPEL Project design meeting. I am reassigning this bug to BPEL project for now.
Comment 4 Ritesh Adval 2006-07-18 21:49:42 UTC
I agree with mike, looks like a side effect of bpel project using java package 
structure or something similiar. Need to be fixed in bpel project.

Comment 5 Ritesh Adval 2006-07-18 21:55:35 UTC
Created attachment 31977 [details]
Bpel and compapp project source packages default packages having java refactoring enabled
Comment 6 Ritesh Adval 2006-07-18 21:57:28 UTC
Looks like a bug in bpel project and comp app which enables java refactoring on 
source Packagesdefault packages.

We should not call it source packages default packages on project view but 
something else
Comment 7 Sreenivasan Genipudi 2006-07-28 03:26:52 UTC
Refactor option should not be supported by BPEL Module. The option is removed.
Comment 8 Mikhail Kondratyev 2006-10-02 08:48:02 UTC
Verified in build from 2006.09.27


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo