Bug 77926 - Reverse engineering breaks diagram and model at all
Reverse engineering breaks diagram and model at all
Status: VERIFIED FIXED
Product: soa
Classification: Unclassified
Component: BPEL
5.x
All All
: P1 (vote)
: 5.x
Assigned To: issues@soa
issues@soa
:
: 77974 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-14 17:21 UTC by Andrey Yamkovoy
Modified: 2006-08-31 02:00 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Yamkovoy 2006-06-14 17:21:03 UTC
Steps to reproduce:
- Create Synchronous sample project.
- Open bpel source editor.
- Add line '<empty name="MyEmpty"/>' (or some another element) inside sequence, 
for example between Receive and Assign activities.
- Switch to diagram view.
- Notice that diagram is out of sync with source and shows incorrect sequence 
of activities.
Comment 1 Denis Anisimov 2006-06-21 09:22:04 UTC
This is fixed now. The problem was in notification from low level XAM with
unrecognized index equals to "-1".
Currently when some element is inserted then all follwong elements fired as 
deleted. Then inserted element fired as added. Then folowing elements are fired 
as added . This firing notify ComponentUpdater with index equls to "-1".
It was incorrectly handled. Now if this index appear with addition action then 
such element will be added to the end of list.
Comment 2 Denis Anisimov 2006-06-22 08:36:10 UTC
*** Issue 77974 has been marked as a duplicate of this issue. ***
Comment 3 Andrey Yamkovoy 2006-07-13 16:21:25 UTC
Fixed.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo