Bug 77699 - UML reverse engineering throws exception
UML reverse engineering throws exception
Status: VERIFIED WORKSFORME
Product: uml
Classification: Unclassified
Component: Diagram Class
5.x
All Windows XP
: P1 (vote)
: TBD
Assigned To: issues@uml
issues@uml
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-11 22:39 UTC by charvener
Modified: 2006-09-29 16:52 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description charvener 2006-06-11 22:39:01 UTC
java.lang.IllegalStateException: Cannot initialize -1th child of node jgo; it
already belongs to node jgo
	at org.openide.nodes.Node.assignTo(Node.java:300)
	at org.openide.nodes.Children$Info.useNodes(Children.java:1226)
	at org.openide.nodes.Children.refreshEntry(Children.java:1102)
	at org.openide.nodes.Children$Array.refreshImpl(Children.java:1357)
	at org.openide.nodes.Children$Array$1.run(Children.java:1374)
	at org.openide.util.Mutex.postRequest(Mutex.java:1113)
	at org.openide.util.Mutex.postWriteRequest(Mutex.java:483)
	at org.openide.nodes.Children$Array.refresh(Children.java:1372)
	at org.openide.nodes.Children$Array.add(Children.java:1419)
	at org.netbeans.modules.uml.project.ui.nodes.UMLChildren.add(UMLChildren.java:51)
	at
org.netbeans.modules.uml.project.ui.nodes.UMLElementNode.addChild(UMLElementNode.java:430)
	at
org.netbeans.modules.uml.project.ui.NetBeansUMLProjectTreeModel.addItem(NetBeansUMLProjectTreeModel.java:225)
	at
org.netbeans.modules.uml.ui.products.ad.projecttreedefaultengine.ADProjectTreeEngine.addDiagram(ADProjectTreeEngine.java:1592)
	at
org.netbeans.modules.uml.ui.products.ad.projecttreedefaultengine.ADProjectTreeEngine.addDiagramNode(ADProjectTreeEngine.java:3065)
[catch] at
org.netbeans.modules.uml.ui.products.ad.projecttreedefaultengine.ADProjectTreeEngine$EngineDrawingAreaSink$1.run(ADProjectTreeEngine.java:3846)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:461)
	at
java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:242)
	at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:163)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:157)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:149)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)
Comment 1 Peter Lam 2006-06-15 00:27:49 UTC
I reverse engineered many java projects but did not see this problem. Could you
please provide more detail on reproducing the problem, eg, which jdk version, is
your java project big or small, steps, anything that helps. Thanks!
Comment 2 Kris Richards 2006-09-21 19:00:23 UTC
this was marked incomplete and unable to reproduce. Time limit expired.
Comment 3 Andrew Korostelev 2006-09-29 16:52:09 UTC
mark as verified not to get bug in 'Resolved/WFM' query (bugs that needs some
clarification from submitter).


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo