Bug 77638 - Starting server in profile mode failed.
Starting server in profile mode failed.
Status: RESOLVED DUPLICATE of bug 92919
Product: profiler
Classification: Unclassified
Component: Base
5.x
PC Windows XP
: P3 (vote)
: 6.x
Assigned To: issues@profiler
issues@profiler
: SPACE_IN_PATH
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-09 16:05 UTC by marcbeckers
Modified: 2007-02-14 16:49 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
See line 19 and 30 (1.67 KB, text/xml)
2006-06-09 16:07 UTC, marcbeckers
Details

Note You need to log in before you can comment on or make changes to this bug.
Description marcbeckers 2006-06-09 16:05:15 UTC
I am able to profile the main project with the bundled Tomcat 5.5.9, but when I
try to do this with Tomcat 5.0 (Java WSDP 1.6) I got the following errors:

profile-j2ee:
start-profiled-server-noenv:
Starting server Tomcat 5.0 (Java WSDP 1.6) in profile mode
Starting Tomcat in profile mode
Waiting for Tomcat...
Starting of Tomcat failed.
E:\LocalCVSWorkingDirectory\waarde-overdracht\projecten\wow\nbproject\profiler-build-impl.xml:19:
The following error occurred while executing this line:
E:\LocalCVSWorkingDirectory\waarde-overdracht\projecten\wow\nbproject\profiler-build-impl.xml:30:
Starting server in profile mode failed.
BUILD FAILED (total time: 1 second)

and

java.lang.NoClassDefFoundError:
Files\netbeans-5/0\profiler1\lib\deployed\jdk15\windows\profilerinterface/dll="D:\Program
Exception in thread "main" 

The probleem is that I need to use the Java WSDP 1.6 version. I am using Windows
XP Professional, NetBeans 5.0, Profiler 5.0 and Tomcat 5.0 (Java WSDP 1.6). Also
see my attachments.

Who can help me???

with kind regards,

Marc Beckers
Comment 1 marcbeckers 2006-06-09 16:07:53 UTC
Created attachment 30919 [details]
See line 19 and 30
Comment 2 Jiri Sedlacek 2006-06-09 16:12:31 UTC
This is caused by space in path based on this log:

java.lang.NoClassDefFoundError:
Files\netbeans-5/0\profiler1\lib\deployed\jdk15
\windows\profilerinterface/dll="D:\Program
Exception in thread "main"

As an immediate workaround, install/copy NetBeans installdir to a path without 
spaces. Also dots shouldn't be used in filenames (netbeans-5.0), it seems that 
they are being translated into "/" (netbeans-5/0).

To be able to evaluate and fix the problem, we need to reproduce it. Could you 
please describe your additional configuration to standard NB install?
Comment 3 Tomas Hurka 2006-06-12 09:18:55 UTC
Please attach your message.log. Thanks.
Comment 4 J Bachorik 2006-08-09 10:10:06 UTC
Duplicate of "space in path" issue.

*** This issue has been marked as a duplicate of 72941 ***
Comment 5 ehucka 2006-09-15 16:48:06 UTC
It doesn't work on linux with fixed issue 72941.
Comment 6 Tomas Hurka 2007-02-14 16:49:35 UTC

*** This issue has been marked as a duplicate of 92919 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo