Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 77492 - Remove impl dep on xml/tax
Remove impl dep on xml/tax
Status: RESOLVED DUPLICATE of bug 147096
Product: xml
Classification: Unclassified
Component: TAX
5.x
All All
: P4 (vote)
: 6.x
Assigned To: issues@xml
issues@xml
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-07 07:36 UTC by Jaroslav Tulach
Modified: 2008-12-01 22:34 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jaroslav Tulach 2006-06-07 07:36:45 UTC
As part of work on split of ideX 
(http://openide.netbeans.org/proposals/arch/clusters.html) it has been 
observed that apisupport/project has implementation dependency on xml/tax. 
This is undesirable even now, but much worse, if those two modules are split 
to independent clusters.

Turn it into some regular contract or remove it.
Comment 1 Jesse Glick 2006-06-09 00:42:03 UTC
Dependent on TAX to expose some API.
Comment 2 Jesse Glick 2006-06-09 00:43:14 UTC
Note that apisupport/project will *probably* switch to XDM (XAM?) for promo H.
Comment 3 Samaresh Panda 2008-12-01 22:34:33 UTC
Fixed as part of issue 147096.

*** This issue has been marked as a duplicate of 147096 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo