Bug 77219 - invalid input focus after refactoring operation
invalid input focus after refactoring operation
Status: RESOLVED WORKSFORME
Product: platform
Classification: Unclassified
Component: Window System
5.x
All Windows XP
: P3 (vote)
: 6.x
Assigned To: Stanislav Aubrecht
issues@platform
: FOCUS
: 77563 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-01 11:22 UTC by Stanislav Aubrecht
Modified: 2009-02-19 22:53 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stanislav Aubrecht 2006-06-01 11:22:29 UTC
the output window steals input focus when a refactoring operation with preview
panel finished even though the editor tab looks like the active one.

Steps to reproduce in 5.0:
1. Create a new class with main method.
2. Run this class (output window opens).
3. Refactor the class - change it's name.
4. Confirm refactoring.
5. Press Ctrl-S once the class is refactored. The focus is in the output window
instead of editor. 

please note that there's no problem when the bottom part of the ide contains
e.g. todo window instead of the output window.
Comment 1 Milos Kleint 2006-06-15 07:55:23 UTC
is the app still running when you do the refactoring? I mean is there a reason
for the output window to do anything? is the window slided to the side or in the
desktop?
Comment 2 Milos Kleint 2006-06-23 13:33:38 UTC
I cannot see how this could be output window related. Once you click into the
refactoring preview TC you are effectively switching active TC. That one gets
closed then immediately and the window system decides which component gets the
focus/activation.

I think I reproduced with todo windows as well.

reassigning to winsys.
Comment 3 David Simonek 2006-08-09 15:06:32 UTC
*** Issue 77563 has been marked as a duplicate of this issue. ***
Comment 4 David Simonek 2006-08-09 15:07:35 UTC
Some reproduction details are in 77563.
Comment 5 Lukas Hasik 2008-04-10 21:23:48 UTC
moving opened issues from TM <= 6.1 to TM=Dev
Comment 6 David Simonek 2008-11-21 13:27:33 UTC
passing to reporter :)
Comment 7 Stanislav Aubrecht 2008-12-08 16:36:26 UTC
i can't reproduce this issue anymore


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo