Bug 77165 - *Code Model* create common threading mechanizm
*Code Model* create common threading mechanizm
Status: RESOLVED FIXED
Product: cnd
Classification: Unclassified
Component: -- Other --
5.x
All All
: P3 (vote)
: 6.x
Assigned To: Vladimir Kvashin
issues@cnd
:
: 75930 (view as bug list)
Depends on:
Blocks: 75930
  Show dependency treegraph
 
Reported: 2006-05-31 15:54 UTC by Vladimir Kvashin
Modified: 2006-06-15 04:52 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Kvashin 2006-05-31 15:54:20 UTC
We know that calls to code model might be expensive; therefore clients (such as,
for example, Class View and Code Completion) call model in a sepatate thread.
For now they use RequestProcessor.getDefault() for this. 

Besides, model implementation uses its own threads (for example, for warmng up
model upon project opening).

It would be fine if model got full control over all these threads. This would
help to solve thread issues.
Comment 1 Vladimir Kvashin 2006-05-31 19:38:20 UTC
Fixed:

- modelapi: Added CsmModel.enqueue method

- modelimpl: added CodeModelRequestProcessor class that is responsible for
threading issues. It in turn uses RequestProcessor.

classview & completion: used  CsmModel.enqueue() instead of
RequestProcessor.getDefault().post()
Comment 2 Vladimir Kvashin 2006-06-15 04:52:12 UTC
*** Issue 75930 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo