Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 77086 - Support for defining generics for Bean components in an easy way
Support for defining generics for Bean components in an easy way
Status: RESOLVED FIXED
Product: guibuilder
Classification: Unclassified
Component: Code
5.x
PC Linux
: P3 (vote)
: 6.x
Assigned To: issues@guibuilder
issues@guibuilder
:
: 63356 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-30 14:42 UTC by Michel Graciano
Modified: 2008-01-09 15:18 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michel Graciano 2006-05-30 14:42:28 UTC
Hi,
if I have some components that is Generics enabled, I can't use it's easely in
NB form editor. I sugest a easy way to define the field declaration, where is
possible include de Generics statement, maybe as Custom Creation option.
For now, I need to cast my component for another field in my code, after
initComponents call.

Regards
Comment 1 Tomas Pavek 2007-07-02 13:37:57 UTC
There is already a "Type Parameters" property in the "Code" properties for each component. Was done for 6.0 already time
ago. It makes the variable declared with the generics. You can set it e.g. to <com.me.MyType> (incl the <> brackets).

Now, I've just fixed the code generation to also generate the types for the constructor call, so the custom creation
code will not be needed.
Comment 2 Tomas Pavek 2007-08-08 10:30:04 UTC
*** Issue 63356 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo