Bug 76806 - Deadlock during CVS diff
Deadlock during CVS diff
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: -- Other --
5.x
PC Linux
: P3 (vote)
: 6.x
Assigned To: issues@editor
issues@editor
: RANDOM, THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-24 14:24 UTC by Marian Petras
Modified: 2007-11-05 13:44 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
full thread dump (26.97 KB, text/plain)
2006-05-24 14:25 UTC, Marian Petras
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marian Petras 2006-05-24 14:24:15 UTC
(NetBeans 5.0, Linux / Fedora Core 4, Intel PC, JDK 1.6.0-b84)

A deadlock occured after I asked the IDE to display a diff of the current file.

I right-clicked on the tab of a file (JUnitAntLogger.java) in the editor and
selected CVS|Diff.... A tab labelled "JUnitAntLogger.java [ Diff ]" was opened
and activated, a progress bar with title 'Diffing "JUnitAntLogger.java" ...'
appeared and the IDE froze.

According to the JRE, the freeze was caused by a deadlock:

Found one Java-level deadlock:
=============================
"Default RequestProcessor":
  waiting to lock monitor 0x08fe670c (object 0x8e7432a0, a java.lang.Class),
  which is held by "AWT-EventQueue-1"
"AWT-EventQueue-1":
  waiting to lock monitor 0x08fe6af4 (object 0x86fe45a8, a
org.netbeans.modules.editor.EditorModule$HackMap),
  which is held by "Default RequestProcessor"

I will attach a full thread dump.
Comment 1 Marian Petras 2006-05-24 14:25:15 UTC
Created attachment 30586 [details]
full thread dump
Comment 2 Maros Sandor 2006-08-07 15:08:21 UTC
I think this is an editor issue, please evaluate.
Comment 3 Vitezslav Stejskal 2007-02-15 01:32:47 UTC
This should be now fixed after the changes made for fixing issue #92449.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo