Bug 76512 - 100% cpu usage / infinite loop on moving object in UML diagram
100% cpu usage / infinite loop on moving object in UML diagram
Status: RESOLVED WORKSFORME
Product: uml
Classification: Unclassified
Component: General Diagram
5.x
All Windows XP
: P1 (vote)
: TBD
Assigned To: Trey Spiva
issues@uml
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-17 18:32 UTC by zcrar70
Modified: 2006-10-16 19:20 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
The project used to reproduce the issue (43.57 KB, application/x-compressed)
2006-05-17 18:32 UTC, zcrar70
Details

Note You need to log in before you can comment on or make changes to this bug.
Description zcrar70 2006-05-17 18:32:16 UTC
Moving an object (not all objects, just this one) in a UML diagram causes 100%
CPU usage (an infinite loop?)

To reproduce: 
open up the attached project in netbeans 5.5 preview (build) with enterprise pack
open up the only diagram int he ValidatorUML project
try moving the "ValidationSet" object in the diagram to the right
 

Hope this helps
Nick
Comment 1 zcrar70 2006-05-17 18:32:47 UTC
Created attachment 30454 [details]
The project used to reproduce the issue
Comment 2 Michal Zlamal 2006-06-21 12:13:10 UTC
I also experience this issue with simple class diagram (on Linux).
While it makes the IDE nearly unusable I'm raising priority to P2, in fact it 
should be P1 while it is performance bug.
Comment 3 Michal Zlamal 2006-08-01 13:49:08 UTC
Since we got no response/reaction in 1.5 month I'm raising the priority to P1 
because it is performance issue and makes UML nearly unusable.
Comment 4 Trey Spiva 2006-09-26 16:36:59 UTC
I am finding that all of the nodes are a little sticky when you first click on
the node.  However, after it starts to move that it is responsive.

However, I am not finding a 100% CPU usage.  You stated that an infinite loop
was being caused, does it CPU usage ever go back to normal or do you have to
kill the NetBeans process?
Comment 5 Peter Lam 2006-09-26 19:35:36 UTC
I tried the same thing on my windows xp laptop with 1GB RAM but could not
reproduce this problem using either the entpack preview or beta version. I also
tried on Linux FC3 remotely through vnc and could not reproduce either.
I think the submitter should try this again using entpack beta to see if it's
still reproducible.
Comment 6 Michal Zlamal 2006-10-04 07:23:32 UTC
It seems like it is working correctly now.
Comment 7 Peter Lam 2006-10-16 19:20:45 UTC
no longer reproducible.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo