Bug 76504 - Exception when dbl-clicking on Invoke element
Exception when dbl-clicking on Invoke element
Status: CLOSED FIXED
Product: soa
Classification: Unclassified
Component: BPEL
5.x
All All
: P1 (vote)
: 5.x
Assigned To: Michael Frisino
issues@soa
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-17 16:50 UTC by Alexander Pepin
Modified: 2006-07-21 10:36 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Pepin 2006-05-17 16:50:43 UTC
Steps to reproduce:
- create a new BPEL module project
- open .bpel in design view
- drag a Invoke activity onto the diagram
- double-click on Invoke element 
Result: Exception window appears.
Annotation: Missing resource from class:
org/netbeans/modules/bpel/properties/editors/Form_ru_RU
Annotation: Key which was not found: 
java.util.MissingResourceException: Can't find bundle for base name
org/netbeans/modules/bpel/properties/editors/Form, locale ru_RU
	at java.util.ResourceBundle.throwMissingResourceException(ResourceBundle.java:836)
	at java.util.ResourceBundle.getBundleImpl(ResourceBundle.java:726)
	at java.util.ResourceBundle.getBundle(ResourceBundle.java:549)
	at
org.netbeans.modules.bpel.properties.editors.InvokeMainPanel.initComponents(InvokeMainPanel.java:87)
	at
org.netbeans.modules.bpel.properties.editors.InvokeMainPanel.createContent(InvokeMainPanel.java:35)
	at
org.netbeans.modules.bpel.properties.editors.InvokeMainPanel.<init>(InvokeMainPanel.java:31)
	at
org.netbeans.modules.bpel.properties.editors.InvokeCustomEditor.createContent(InvokeCustomEditor.java:47)
	at
org.netbeans.modules.bpel.properties.editors.InvokeCustomEditor.<init>(InvokeCustomEditor.java:35)
	at
org.netbeans.modules.bpel.properties.nodes.InvokeNode.getCustomizer(InvokeNode.java:112)
	at
org.netbeans.modules.bpel.properties.props.CustomEditorProperty$MyCustomEditor.getCustomEditor(CustomEditorProperty.java:82)
	at
org.openide.explorer.propertysheet.PropertyDialogManager.<init>(PropertyDialogManager.java:105)
	at
org.openide.explorer.propertysheet.CustomEditorAction.actionPerformed(CustomEditorAction.java:196)
	at
org.openide.explorer.propertysheet.SheetTable.processMouseEvent(SheetTable.java:679)
	at java.awt.Component.processEvent(Component.java:5253)
	at java.awt.Container.processEvent(Container.java:1966)
	at java.awt.Component.dispatchEventImpl(Component.java:3955)
	at java.awt.Container.dispatchEventImpl(Container.java:2024)
	at java.awt.Component.dispatchEvent(Component.java:3803)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4212)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:3889)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:3822)
	at java.awt.Container.dispatchEventImpl(Container.java:2010)
	at java.awt.Window.dispatchEventImpl(Window.java:1774)
	at java.awt.Component.dispatchEvent(Component.java:3803)
[catch] at java.awt.EventQueue.dispatchEvent(EventQueue.java:463)
	at
java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:242)
	at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:163)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:157)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:149)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)
Comment 1 Alexander Pepin 2006-06-23 12:49:59 UTC
The issue is not reproducible in build 060620 so it can be considered as fixed.
Comment 2 Alexander Pepin 2006-06-23 13:03:26 UTC
see comments above


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo