Bug 76483 - Exception when clicking on Receive/Reply
Exception when clicking on Receive/Reply
Status: CLOSED FIXED
Product: soa
Classification: Unclassified
Component: BPEL
5.x
All All
: P1 (vote)
: 5.x
Assigned To: Michael Frisino
issues@soa
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-17 13:51 UTC by Alexander Pepin
Modified: 2006-07-21 10:35 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Pepin 2006-05-17 13:51:59 UTC
Steps to reproduce:
- create a new BPEL module project
- open .bpel in design view
- drag a Receive or Reply activity onto the diagram
- click on Receive/Reply element 
Result: Exception window appears.
java.lang.NoSuchMethodException:
org.netbeans.modules.bpel.model.api.Receive.setMessageExchange(java.lang.String)
	at java.lang.Class.getMethod(Class.java:1581)
	at
org.netbeans.modules.bpel.properties.props.PropertyUtils$Reflection.<init>(PropertyUtils.java:394)
	at
org.netbeans.modules.bpel.properties.props.PropertyUtils.registerPropertyImpl(PropertyUtils.java:118)
	at
org.netbeans.modules.bpel.properties.props.PropertyUtils.registerAttributeProperty(PropertyUtils.java:90)
	at
org.netbeans.modules.bpel.properties.nodes.ReceiveNode.createSheet(ReceiveNode.java:113)
	at org.openide.nodes.AbstractNode.getSheet(AbstractNode.java:398)
	at org.openide.nodes.AbstractNode.getPropertySets(AbstractNode.java:409)
	at
org.openide.explorer.propertysheet.PropertySheet.setCurrentNode(PropertySheet.java:558)
	at
org.openide.explorer.propertysheet.PropertySheet.doSetNodes(PropertySheet.java:375)
	at
org.openide.explorer.propertysheet.PropertySheet.access$300(PropertySheet.java:79)
[catch] at
org.openide.explorer.propertysheet.PropertySheet$2$1.run(PropertySheet.java:517)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:461)
	at
java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:242)
	at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:163)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:157)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:149)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)
Comment 1 Alexander Pepin 2006-06-23 12:48:43 UTC
The issue is not reproducible in build 060620 so it can be considered as fixed.
Comment 2 Alexander Pepin 2006-06-23 13:06:18 UTC
see comments above


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo