Bug 75909 - No longer compiles scripts it used to compile
No longer compiles scripts it used to compile
Status: RESOLVED FIXED
Product: contrib
Classification: Unclassified
Component: Jackpot
5.x
All All
: P1 (vote)
: 6.x
Assigned To: issues@contrib
issues@contrib
: REGRESSION
Depends on:
Blocks: 35067
  Show dependency treegraph
 
Reported: 2006-05-04 11:11 UTC by Jaroslav Tulach
Modified: 2006-06-22 08:33 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jaroslav Tulach 2006-05-04 11:11:30 UTC
After getting today's build and today's jackpot from AU, I get:

org.netbeans.jackpot.engine.EngineException: Error executing operator
	at org.netbeans.jackpot.builder.Engine.runScript(Engine.java:160)
	at 
org.netbeans.modules.jackpot.JackpotModule.runCommand(JackpotModule.java:131)
	at 
org.netbeans.modules.jackpot.actions.JackpotAction$CommandRunner.run(JackpotAction.java:81)
[catch] at java.lang.Thread.run(Thread.java:595)
Caused by: org.netbeans.jackpot.engine.EngineException: script compilation 
failed
	at 
org.netbeans.jackpot.builder.Engine.createScriptClass(Engine.java:182)
	at org.netbeans.jackpot.builder.Engine.runScript(Engine.java:143)
	... 3 more
Caused by: java.lang.NullPointerException
	at java.io.Writer.write(Writer.java:126)
	at 
org.netbeans.jackpot.script.PluginCompiler.write(PluginCompiler.java:165)
	at 
org.netbeans.jackpot.script.TransformParser$RewriteConstructor.visitLiteral(TransformParser.java:784)
	at com.sun.tools.javac.tree.JCTree$JCLiteral.accept(JCTree.java:1566)
	at 
org.netbeans.jackpot.script.TransformParser$Constructor.generate(TransformParser.java:322)
	at 
org.netbeans.jackpot.script.TransformParser$Constructor.generate(TransformParser.java:375)
	at org.netbeans.jackpot.script.TransformParser$Constructor.generate2
(TransformParser.java:338)
	at 
org.netbeans.jackpot.script.TransformParser$Constructor.generate(TransformParser.java:367)
	at 
org.netbeans.jackpot.script.TransformParser$RewriteConstructor.visitApply(TransformParser.java:605)
	at 
com.sun.tools.javac.tree.JCTree$JCMethodInvocation.accept(JCTree.java:1206)
	at 
org.netbeans.jackpot.script.TransformParser$Constructor.generate(TransformParser.java:322)
	at 
org.netbeans.jackpot.script.TransformParser$Replacement.write(TransformParser.java:1875)
	at 
org.netbeans.jackpot.script.TransformParser$Replacement.writeAll(TransformParser.java:1823)
	at 
org.netbeans.jackpot.script.TransformParser$Guard.writeWrapped(TransformParser.java:1739)
	at 
org.netbeans.jackpot.script.TransformParser$Guard.writeAll(TransformParser.java:1699)
	at 
org.netbeans.jackpot.script.TransformParser$Guard.writeWrapped(TransformParser.java:1739)
	at 
org.netbeans.jackpot.script.TransformParser$Guard.writeAll(TransformParser.java:1699)
	at 
org.netbeans.jackpot.script.TransformParser$Guard.writeWrapped(TransformParser.java:1739)
	at 
org.netbeans.jackpot.script.TransformParser$Guard.writeAll(TransformParser.java:1699)
	at 
org.netbeans.jackpot.script.TransformParser$Guard.writeWrapped(TransformParser.java:1739)
	at 
org.netbeans.jackpot.script.TransformParser$Guard.writeAll(TransformParser.java:1699)
	at 
org.netbeans.jackpot.script.TransformParser$Guard.writeWrapped(TransformParser.java:1739)
	at 
org.netbeans.jackpot.script.TransformParser$Guard.writeAll(TransformParser.java:1699)
	at 
org.netbeans.jackpot.script.TransformParser$Guard.writeWrapped(TransformParser.java:1739)
	at 
org.netbeans.jackpot.script.TransformParser$Guard.writeAll(TransformParser.java:1699)
	at 
org.netbeans.jackpot.script.TransformParser$Guard.writeWrapped(TransformParser.java:1739)
	at 
org.netbeans.jackpot.script.TransformParser$Guard.writeAll(TransformParser.java:1699)
	at 
org.netbeans.jackpot.script.TransformParser$Guard.writeWrapped(TransformParser.java:1739)
	at 
org.netbeans.jackpot.script.TransformParser$Guard.writeAll(TransformParser.java:1699)
	at 
org.netbeans.jackpot.script.TransformParser$Guard.writeWrapped(TransformParser.java:1739)
	at 
org.netbeans.jackpot.script.TransformParser$Guard.writeAll(TransformParser.java:1699)
	at 
org.netbeans.jackpot.script.TransformParser$Guard.writeWrapped(TransformParser.java:1739)
	at 
org.netbeans.jackpot.script.TransformParser$Guard.writeAll(TransformParser.java:1699)
	at 
org.netbeans.jackpot.script.TransformParser$Guard.writeWrapped(TransformParser.java:1742)
	at 
org.netbeans.jackpot.script.TransformParser$Guard.writeAll(TransformParser.java:1723)
	at 
org.netbeans.jackpot.script.TransformParser$Guard.writeWrapped(TransformParser.java:1739)
	at 
org.netbeans.jackpot.script.TransformParser$Guard.writeAll(TransformParser.java:1699)
	at 
org.netbeans.jackpot.script.TransformParser$Guard.writeWrapped(TransformParser.java:1739)
	at 
org.netbeans.jackpot.script.TransformParser$Guard.writeAll(TransformParser.java:1699)
	at 
org.netbeans.jackpot.script.TransformParser$Guard.writeWrapped(TransformParser.java:1739)
	at 
org.netbeans.jackpot.script.TransformParser$Guard.writeAll(TransformParser.java:1699)
	at 
org.netbeans.jackpot.script.TransformParser$Guard.writeWrapped(TransformParser.java:1739)
	at 
org.netbeans.jackpot.script.TransformParser$Guard.writeAll(TransformParser.java:1699)
	at 
org.netbeans.jackpot.script.TransformParser$Guard.writeWrapped(TransformParser.java:1739)
	at 
org.netbeans.jackpot.script.TransformParser$Guard.writeAll(TransformParser.java:1699)
	at 
org.netbeans.jackpot.script.TransformParser$Guard.writeWrapped(TransformParser.java:1739)
	at 
org.netbeans.jackpot.script.TransformParser$Guard.writeAll(TransformParser.java:1699)
	at 
org.netbeans.jackpot.script.TransformParser$Guard.writeWrapped(TransformParser.java:1739)
	at 
org.netbeans.jackpot.script.TransformParser$Guard.writeAll(TransformParser.java:1699)
	at 
org.netbeans.jackpot.script.TransformParser$Guard.writeWrapped(TransformParser.java:1739)
	at 
org.netbeans.jackpot.script.TransformParser$Guard.writeAll(TransformParser.java:1723)
	at 
org.netbeans.jackpot.script.TransformParser$Guard.writeWrapped(TransformParser.java:1739)
	at 
org.netbeans.jackpot.script.TransformParser$Guard.writeAll(TransformParser.java:1699)
	at 
org.netbeans.jackpot.script.TransformParser$Guard.writeWrapped(TransformParser.java:1739)
	at 
org.netbeans.jackpot.script.TransformParser$Guard.writeAll(TransformParser.java:1699)
	at 
org.netbeans.jackpot.script.TransformParser$Guard.writeWrapped(TransformParser.java:1739)
	at 
org.netbeans.jackpot.script.TransformParser$Guard.writeAll(TransformParser.java:1699)
	at 
org.netbeans.jackpot.script.TransformParser$Guard.writeWrapped(TransformParser.java:1739)
	at 
org.netbeans.jackpot.script.TransformParser$Guard.writeAll(TransformParser.java:1699)
	at 
org.netbeans.jackpot.script.TransformParser$Guard.writeWrapped(TransformParser.java:1739)
	at 
org.netbeans.jackpot.script.TransformParser$Guard.writeAll(TransformParser.java:1699)
	at 
org.netbeans.jackpot.script.TransformParser$Guard.writeWrapped(TransformParser.java:1739)
	at 
org.netbeans.jackpot.script.TransformParser$Guard.writeAll(TransformParser.java:1699)
	at 
org.netbeans.jackpot.script.TransformParser.codeRules(TransformParser.java:287)
	at 
org.netbeans.jackpot.builder.Engine.createScriptClass(Engine.java:174)
	... 4 more
Comment 1 Jaroslav Tulach 2006-05-04 11:12:17 UTC
The script is available as part of apisupport/jackpotrules module and is named 
ErrorManager -> Logger
Comment 2 _ tball 2006-05-04 15:40:01 UTC
This is very strange.  I can certainly believe the bug exists, but why it showed
up today doesn't make sense since I haven't updated the Jackpot binaries in two
weeks due to the UI re-work.  I'll verify this works before committing the new
UI, hopefully this afternoon.
Comment 3 Jaroslav Tulach 2006-05-04 16:45:24 UTC
Well, I have not used jackpot for a month or so...
Comment 4 Jaroslav Tulach 2006-06-02 18:39:46 UTC
Is this really that hard to fix? It is de-facto blocking issue 35067 which is 
P1, without fixing this I really do not know how to move my development 
forward.
Comment 5 _ tball 2006-06-02 21:45:05 UTC
Nothing is too hard to fix, but JavaOne warped all of my normal priorities and
I'm still catching up.  The problem is to the javac team gratuitously changed
the internal values of several literal types a few Mustang builds ago, which
broke the rule parser in several places.  Maybe they need to hear your lecture
on what constitutes an API. :-)

I fixed all the damage yesterday, but now the netbeans.czech server where the
jackpot/retouche repository lives is not accessible from California (again). 
Between that and Monday's SourceForge update I probably won't be able to get
anything pushed to the update center until Wednesday (push on Tuesday before the
daily build starts, then wait for RE to copy the files over the next day).  If
you want the modules from my private build sooner, let me know and I'll put them
on cdp-atg.sfbay and send you a pointer.
Comment 6 Jaroslav Tulach 2006-06-06 16:32:19 UTC
I can take the bits from netbeans.org CVS. If you put they in before tomorrow, 
I'll be thankful as issue 35067 is mostly finished, I really need just the 
jackpot rule.
Comment 7 _ tball 2006-06-07 00:56:00 UTC
I can't commit to cvs.netbeans.org, either directly from my home account or
indirectly via a SOCKS proxy inside SWAN or using cvsnetbeansorg.sfbay.  I'll
try again first thing tomorrow.  FYI, when running your query I saw some
unnecessary diffs, so I'll be working on eliminating those after this push.  

Also, do you want me to update your module's layer.xml to use the scheme
introduced by the new UI?  I can also create a "NetBeans Modules" query set
there if yo want, so all of your rule files can be run as a single action.
Comment 8 _ tball 2006-06-07 00:56:17 UTC
I can't commit to cvs.netbeans.org, either directly from my home account or
indirectly via a SOCKS proxy inside SWAN or using cvsnetbeansorg.sfbay.  I'll
try again first thing tomorrow.  FYI, when running your query I saw some
unnecessary diffs, so I'll be working on eliminating those after this push.  

Also, do you want me to update your module's layer.xml to use the scheme
introduced by the new UI?  I can also create a "NetBeans Modules" query set
there if you want, so all of your rule files can be run as a single action.
Comment 9 Jesse Glick 2006-06-07 01:02:54 UTC
I already updated apisupport/jackpotrules to use what I think is the new
registration syntax, though it would be great if you could take a look and
confirm that it is right. I haven't tried using it yet.
Comment 10 Jaroslav Tulach 2006-06-22 08:33:42 UTC
Seems to be fixed.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo