Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 75858 - Cannot open NB projects.
Cannot open NB projects.
Status: VERIFIED FIXED
Product: versioncontrol
Classification: Unclassified
Component: CVS
5.x
All All
: P3 (vote)
: 6.x
Assigned To: issues@versioncontrol
issues@versioncontrol
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-03 15:55 UTC by Peter Pis
Modified: 2007-01-12 11:01 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
thread dump (16.60 KB, text/plain)
2006-05-03 15:56 UTC, Peter Pis
Details
message log (36.22 KB, text/plain)
2006-05-03 16:09 UTC, Peter Pis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Pis 2006-05-03 15:55:26 UTC
Product Version         = NetBeans 5.5 Beta (Build 200605030200)
Operating System        = Linux version 2.6.9-1.667 running on i386
Java; VM; Vendor; Home  = 1.5.0_06; Java HotSpot(TM) Client VM 1.5.0_06-b05

Try to open NB project (subversion/main - without dependencies). IDE hangs.
Comment 1 Peter Pis 2006-05-03 15:56:21 UTC
Created attachment 30217 [details]
thread dump
Comment 2 Peter Pis 2006-05-03 16:08:35 UTC
This in case there are installed all modules for Subversion. 

In case of standard distribution of NB exceptions are thrown. See attached
message.log.
Comment 3 Peter Pis 2006-05-03 16:09:19 UTC
Created attachment 30218 [details]
message log
Comment 4 Jan Lahoda 2006-05-03 18:36:52 UTC
Hi,
   I think there are two different things:
1. the deadlock is caused by calling ProjectManager.findProject recursivelly -
this cannot work (please see issue #60073 and issue #60011). Reassigning to
subversion - see jglick's comment to issue #60011, point 1.
2. The exceptions: I do not think this has anything to do with project
infrastructure: the first exception is:
ava.lang.RuntimeException: DOM graph creation failed:
org.netbeans.modules.schema2beans.Schema2BeansRuntimeException: Failed to create
the XML-DOM Document.  Check your XML to make sure it is correct.
Premature end of file.
at
org.netbeans.modules.websvc.jaxwsmodel.project_config1_0.JaxWs.createGraph(JaxWs.java:216)
=>I think this is bug in jaxwsmodel. Could you please file a bug against module?
Comment 5 Tomas Stupka 2006-05-04 11:39:09 UTC
i agree, it seems to be two different things so we should hadle it in two issues.

1. the call on xxx.cvss.FilesystemHandler.notManaged() should be done in a
separate thread. actually the same way as in the event handling fix from msandor
for #60011. will take care for it.

2. new issue #75910

Comment 6 Peter Pis 2006-05-04 14:48:35 UTC
*** Issue 75925 has been marked as a duplicate of this issue. ***
Comment 7 Tomas Stupka 2006-05-11 18:21:48 UTC
made a quick-fix in cvs so a deadlock should not appear anymore.
it checks if the given file is managed by traversing the parent folder and
looking for a cvs/root file. this could be quite expensive so it's still to
evaluate if there is no another solution ...

no deadlock so lowering the priority to p3
Comment 8 Maros Sandor 2007-01-10 11:08:39 UTC
The code is now completely rewritten. The root cause was that CVS filesystem
handler depended on the status cache in a way that could cause deadlocks. Now
event handling does not query status cache at all so this issue should be fixed.
Comment 9 Peter Pis 2007-01-12 11:01:44 UTC
Verified.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo