Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 75840 - Import project wizard wants WEB-INF to be simultaneously present and not present
Import project wizard wants WEB-INF to be simultaneously present and not present
Status: RESOLVED FIXED
Product: javaee
Classification: Unclassified
Component: Web Project
5.x
Sun Solaris
: P3 (vote)
: 6.x
Assigned To: Radko Najman
issues@javaee
:
Depends on: 89479
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-03 14:06 UTC by alanbur
Modified: 2007-04-25 14:34 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description alanbur 2006-05-03 14:06:53 UTC
I'm trying to create a new web application with existing sources, using the
Wizard.  My app already has a WEB-INF project.  The first screen of the wizard
('Add existing sources') reports an error at the bottom of the screen, saying
'Project Folder already contains "WEB-INF" folder'.  If I delete the folder (or
just it's contents) and try again I get past the first screen but then get an
error on the second screen saying 'WEB-INF directory cannot be found in ....'
Comment 1 Radko Najman 2006-05-03 14:51:00 UTC
I guess that the first error message is shown because you want to create the
project in the same location as your WEB-INF is placed which is not allowed. If
you delete it, the second error is shown because without WEB-INF directory the
project cannot be created correctly.
Try to specify different location for your project and it should work.
Comment 2 alanbur 2006-05-03 18:18:36 UTC
That makes no sense to me - you appear to be saying that the directory has to be
simultaneously present and absent.

This problem disappeared when I blew away my $HOME/.netbeans project - could the
problem be that if a project fails to create it leaves cruft under there that
causes breakage if another attempt is made to create the project?
Comment 3 Radko Najman 2006-05-04 08:50:23 UTC
I wanted to say that project folder cannot be on the same level as WEB-INF folder.
Comment 4 alanbur 2006-05-04 09:23:53 UTC
It isn't, the WEB-INF directory was a subdirectory of the project directory.
Comment 5 Radko Najman 2006-05-04 10:05:07 UTC
Could you describe your source structure or attach a simple application to
reproduce it with?
Comment 6 Radko Najman 2007-01-15 14:32:33 UTC
Probably could be solved by issue #89479.
Comment 7 Radko Najman 2007-04-25 14:34:51 UTC
Hopefully fixed by issue #64088.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo