Bug 75643 - UML adds invalid imports to Java source files.
UML adds invalid imports to Java source files.
Status: RESOLVED WORKSFORME
Product: uml
Classification: Unclassified
Component: Code Generation
5.x
Macintosh Mac OS X
: P1 (vote)
: 6.x
Assigned To: Kris Richards
issues@uml
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-27 19:45 UTC by dafreels
Modified: 2007-05-23 13:01 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Screen capture of invalid imports. (14.22 KB, image/png)
2006-04-27 20:33 UTC, dafreels
Details

Note You need to log in before you can comment on or make changes to this bug.
Description dafreels 2006-04-27 19:45:38 UTC
I have reverse engineered my project (Java Project w/existing sources) into UML.
Now, when I go back into the source and change method signatures, the UML
project keeps adding imports to an object, but it doesn't include the package.
Example:

java.test.ImportedObject

appears in my file as import ImportedObject; causing the source editor to show
an error. This prevents me from orginizing imports because that will not execute
when errors are present so I have to remove the bad import and then orginize.
The class javadoc comment also gets an extra line each time the UML project
decides to fix my imports.
Comment 1 dafreels 2006-04-27 20:33:25 UTC
Created attachment 30114 [details]
Screen capture of invalid imports.
Comment 2 Peter Lam 2006-06-01 11:41:39 UTC
known issue.
Comment 3 Kris Richards 2006-09-21 18:53:21 UTC
This bug will go away when live roundtrip is removed.
Comment 4 Kris Richards 2006-09-21 18:55:28 UTC
verify after live round trip is removed.
Comment 5 George Vasick 2007-05-18 19:22:06 UTC
Needs to be verified in NB 6.0.
Comment 6 Andrew Korostelev 2007-05-23 13:01:08 UTC
not reproducible after live round trip is removed.
can't reproduce with nb6.0 RE/CodeGen feature.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo