Bug 755 - External deleting .java file do not close opened editor.
External deleting .java file do not close opened editor.
Status: CLOSED DUPLICATE of bug 19796
Product: platform
Classification: Unclassified
Component: Text
3.x
All All
: P4 (vote)
: TBD
Assigned To: Peter Zavadsky
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 1998-09-25 19:07 UTC by Jan Jancura
Modified: 2008-12-23 10:34 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Jancura 1998-09-25 19:07:00 UTC
External deleting .java file do not cloze opened editor. If sb wants to close editor manually, exception occurres:


java.lang.ArrayIndexOutOfBoundsException: 1 >= 1
	at java.util.Vector.elementAt(Vector.java:328)
	at com.sun.java.swing.JTabbedPane.setIconAt(JTabbedPane.java:772)
	at com.netbeans.developer.base.windows.MultiObjectFrame.updateIcons(MultiObjectFrame.java:336)
	at com.netbeans.developer.base.windows.MultiObjectFrame.access$8(MultiObjectFrame.java:330)
	at com.netbeans.developer.base.windows.MultiObjectFrame$5.propertyChange(MultiObjectFrame.java:250)

	at com.netbeans.developer.util.node.Node.fireOwnPropertyChange(Node.java:280)

	at com.netbeans.developer.util.node.Node.fireIconChange(Node.java:213)
	at com.netbeans.developerx.loaders.java.JavaNode.resolveIcons(JavaNode.java:357)
	at com.netbeans.developerx.loaders.java.JavaNode$3.run(JavaNode.java:321)
	at com.netbeans.developer.util.RequestProcessor$1.execute(RequestProcessor.java:64)
	at sunw.hotjava.misc.RequestProcessor.run(RequestProcessor.java:130)
	at java.lang.Thread.run(Thread.java:474)
Comment 1 Marek Grummich 2000-07-25 09:25:59 UTC
Priority is changed to P4 (normal).
Comment 2 Marian Mirilovic 2002-01-11 16:53:40 UTC
reopen, ArrayIndexOutOfBoundsException still arise and Editor isn't
closed after deletion .java file externally.

Comment 3 _ ttran 2002-01-14 07:31:51 UTC
although the original stack trace is useless now, people seem still
have problems.  Problem is likely in editor support.  pzavadsky please
investigate
Comment 4 Peter Zavadsky 2002-01-18 13:22:19 UTC
Marian please, put in the new stack trace. The old one is useless. Thanks
Comment 5 Marian Mirilovic 2002-01-25 17:21:54 UTC

*** This issue has been marked as a duplicate of 19796 ***
Comment 6 Quality Engineering 2003-07-02 15:23:15 UTC
Resolved for 3.4.x or earlier, no new info since then -> verify.

Comment 7 Quality Engineering 2003-07-02 15:43:18 UTC
Resolved for 3.4.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo