Bug 75339 - Reconsider an alternative to the SVN cmd line client
Reconsider an alternative to the SVN cmd line client
Status: RESOLVED FIXED
Product: versioncontrol
Classification: Unclassified
Component: Subversion
6.x
All All
: P2 (vote)
: 6.x
Assigned To: issues@versioncontrol
issues@versioncontrol
: PLAN
: 114832 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-21 13:28 UTC by Peter Pis
Modified: 2008-08-12 14:50 UTC (History)
5 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Pis 2006-04-21 13:28:15 UTC
Some commands can work more relaible with the usage of JavaHL for windows.
Comment 1 Tomas Stupka 2007-01-02 10:32:01 UTC
there are some known alternatives to the currently used cmd line client
- javahl
- svnkit (javasvn)

each one brings its own specific issues (deployment, licensing, etc.), but it is
to reconsider if we could use or at least support them in the future.
Comment 2 Tomas Stupka 2007-01-02 10:32:20 UTC
*** Issue 89497 has been marked as a duplicate of this issue. ***
Comment 3 augusto_sellhorn 2007-03-17 19:17:16 UTC
In the comments for 89497 it's mentioned that SNVKit can not be used as part of
Netbeans because of license issues. Can somebody please elaborate what this
means? Other open source projects use it, even Hudson uses it, but somebody in
that other issue commented specifically that their license was incompatible with
the one used by Netbeans.

I read the "TMate Open Source License" and don't see what's the problem:
http://svnkit.com/license.html

Of course INAL and all of that, but it'd be great to hear in more detail why
this is a problem. The ideal solution would be to just include this in Netbeans
out of the box, since it's much more simpler than using external tools and
linking them to the Netbeans SVN support. Writting this again, doesn't make much
sense when there's a product that works very well and seems to have a very
healthy community.
Comment 4 _ gtzabari 2007-06-12 20:48:09 UTC
I wrote to TMate and they replied:

"
TMate Open Source license allows to redistribute SVNKit along with application in case all application source code is
publicly available.

However, sometime ago I was contacted by NetBeans and was said that NetBeans IDE includes closed-source parts (Java
compiler if I recall correctly). In case NetBeans still includes closed-source components (I'm not sure about that and
most probably today NetBeans is completely open sourced) they have to obtain commercial SVNKit license. Same is correct
for closed-source applications built on top of NetBeans platform.
"

I also read at http://www.javalobby.org/forums/thread.jspa?threadID=97125 that javac is no longer close-sourced. As
such, can the Netbeans team please revisit this issue?
Comment 5 arseniy 2007-06-14 12:37:30 UTC
yes it's on our radar for some time and we do plan to revise after NetBeans 6.0.
Comment 6 Peter Pis 2007-09-06 08:58:14 UTC
*** Issue 114832 has been marked as a duplicate of this issue. ***
Comment 7 javydreamercsw 2008-03-03 16:42:47 UTC
This would be great! The only let down of current subversion support is the need for the external installation. This
would raise the bar a lot.
Comment 8 Tomas Pavek 2008-05-29 17:29:43 UTC
We plan to support javahl for 6.5. That should solve couple of problems we have with CLI.
Svnkit is still not an option - we can't ensure that everything built on NetBeans has all code publicly available (open
source).
Comment 9 Tomas Pavek 2008-08-12 14:50:43 UTC
This is done, for NB 6.5 we support JavaHL from Subversion 1.5. It gets used automatically if you have SVN 1.5
installed. Cmd line is still used if present and JavaHL not available (e.g. for SVN 1.4.x). If not having SVN installed,
an option to automatically download it as a NB plugin from auto update is offered (only for Windows). Should be
available from NB 6.5 beta.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo