Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 75238 - Sample midlet isn't generated for some return types in Mobile Client to Web Application
Sample midlet isn't generated for some return types in Mobile Client to Web A...
Status: VERIFIED FIXED
Product: javame
Classification: Unclassified
Component: Web Services
6.x
PC All
: P3 (vote)
: 6.x
Assigned To: Michal Skvor
issues@mobility
: REGRESSION, RELNOTE
: 81695 98846 99752 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-19 14:06 UTC by Lukas Hasik
Modified: 2007-08-24 13:47 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
project that is causing this problem (73.89 KB, application/x-compressed)
2006-04-24 12:51 UTC, Lukas Hasik
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lukas Hasik 2006-04-19 14:06:58 UTC
build 0419

-when user creates new Mobile Client to Web Application then the Sample Midlet
isn't generated. This happens only on Linux (Fedora Cora). It works on Windows.
Comment 1 Lukas Hasik 2006-04-24 12:51:28 UTC
Created attachment 30008 [details]
project that is causing this problem
Comment 2 Lukas Hasik 2006-04-24 13:09:04 UTC
doesn't work on windows with provided project too
Comment 3 Michal Skvor 2006-04-24 13:27:52 UTC
The sample MIDlet is not generated because return type of the web service
returns types not suitable for visual development such as array of bytes. Visual
editor does not now howto reprsent these data so the MIDlet is not generated.
This should be fixed into 6.0 version of Mobilty Pack
Comment 4 Lukas Hasik 2006-04-24 20:15:55 UTC
when it should be fixed then it cannot be cosed as wontfix ;)

reopening, decreasing priority and setting the right Target milestone.

For 5.5 - list in release notes
for 6.0 - fix 
        - possible solutions: 1, disable Sample midlet when it doesn't know how
to handle the objects and provide a warning message
           2, generate the SampleMidlet with simple handling of the objects
(like for complex types)
Comment 5 Lukas Hasik 2006-06-23 15:08:28 UTC
moving to mobility component
Comment 6 sigalduek 2006-08-03 05:56:52 UTC
*** Issue 81695 has been marked as a duplicate of this issue. ***
Comment 7 Lukas Hasik 2007-03-26 20:12:01 UTC
*** Issue 98846 has been marked as a duplicate of this issue. ***
Comment 8 Lukas Hasik 2007-04-03 09:28:29 UTC
*** Issue 99752 has been marked as a duplicate of this issue. ***
Comment 9 Michal Skvor 2007-07-30 15:25:40 UTC
There won't be sample MIDlet feature in 6.0 version. Closing as fixed.
Comment 10 Lukas Hasik 2007-08-24 13:47:51 UTC
the decision is - "No sample midlet will be generated".

marking as verified.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo