Bug 75157 - H files and last line
H files and last line
Status: RESOLVED DUPLICATE of bug 75885
Product: cnd
Classification: Unclassified
Component: -- Other --
5.x
All All
: P4 (vote)
: 6.x
Assigned To: Vladimir Kvashin
issues@cnd
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-18 13:52 UTC by soldatov
Modified: 2007-09-06 18:06 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description soldatov 2006-04-18 13:52:01 UTC
I installed latest build and found this problem with code folds.

Steps:
- Create "Welcome" sample project
- Open "welcome.h" in built-in editor
- Remove last line in file (empty line)
- Close file in built-in editor
- Open "welcome.h" in built-in editor again
- Folds are broken (code folds)
- cat ~/.netbeans/5.0/var/log/messages.log

------------------------------------------------------
exception: line 10:25: unexpected char: 0xFFFF
line 10:25: unexpected char: 0xFFFF
        at
org.netbeans.modules.cnd.modelimpl.antlr.CPPFoldingLexer.nextToken(CPPFoldingLexer.java:390)
        at antlr.TokenBuffer.fill(TokenBuffer.java:69)
        at antlr.TokenBuffer.LA(TokenBuffer.java:80)
        at antlr.LLkParser.LA(LLkParser.java:52)
        at
org.netbeans.modules.cnd.modelimpl.antlr.CPPFoldingParser.translation_unit(CPPFoldingParser.java:139)
        at
org.netbeans.modules.cnd.modelimpl.antlr.CPPFoldingParser.parse(CPPFoldingParser.java:69)
        at
org.netbeans.modules.cnd.modelimpl.csm.core.FileParser.parse(FileParser.java:41)
        at
org.netbeans.modules.cnd.editor.parser.CppFile.startParsing(CppFile.java:120)
        at
org.netbeans.modules.cnd.editor.parser.CppFile.startParsing(CppFile.java:98)
        at
org.netbeans.modules.cnd.editor.parser.CppMetaModel$1.run(CppMetaModel.java:70)
        at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:493)
        at
org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:926)
Comment 1 Vladimir Voskresensky 2006-05-06 13:34:37 UTC

*** This issue has been marked as a duplicate of 75885 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo